<!DOCTYPE html>
<html lang="en-US">
<head>
	<meta charset="UTF-8"/>
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="https://gmpg.org/xfn/11"/>
	<title>Man shot dead in Linstead - Jamaica Beacon</title>
<script type='text/javascript'>function ctSetCookie(c_name, value, def_value){document.cookie = c_name + '=' + escape(value) + '; path=/';}ctSetCookie('ct_checkjs', '956495098', '0');</script>
<!-- This site is optimized with the Yoast SEO plugin v12.9.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="The deceased is 44-year-old Neville Thomas."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://jamaicabeacon.com/linstead-news/killing-in-linstead" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Man shot dead in Linstead - Jamaica Beacon" />
<meta property="og:description" content="The deceased is 44-year-old Neville Thomas." />
<meta property="og:url" content="https://jamaicabeacon.com/linstead-news/killing-in-linstead" />
<meta property="og:site_name" content="Jamaica Beacon" />
<meta property="article:tag" content="murder" />
<meta property="article:tag" content="Neville Thomas" />
<meta property="article:section" content="LINSTEAD" />
<meta property="article:published_time" content="2020-02-11T10:36:06+00:00" />
<meta property="article:modified_time" content="2020-02-11T12:29:45+00:00" />
<meta property="og:updated_time" content="2020-02-11T12:29:45+00:00" />
<meta property="og:image" content="https://jamaicabeacon.com/wp-content/uploads/2019/03/police-1.jpg" />
<meta property="og:image:secure_url" content="https://jamaicabeacon.com/wp-content/uploads/2019/03/police-1.jpg" />
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="573" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="The deceased is 44-year-old Neville Thomas." />
<meta name="twitter:title" content="Man shot dead in Linstead - Jamaica Beacon" />
<meta name="twitter:image" content="https://jamaicabeacon.com/wp-content/uploads/2019/03/police-1.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://jamaicabeacon.com/#website","url":"https://jamaicabeacon.com/","name":"Jamaica Beacon","description":"The home of success","potentialAction":{"@type":"SearchAction","target":"https://jamaicabeacon.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://jamaicabeacon.com/linstead-news/killing-in-linstead#primaryimage","url":"https://jamaicabeacon.com/wp-content/uploads/2019/03/police-1.jpg","width":800,"height":573},{"@type":"WebPage","@id":"https://jamaicabeacon.com/linstead-news/killing-in-linstead#webpage","url":"https://jamaicabeacon.com/linstead-news/killing-in-linstead","inLanguage":"en-US","name":"Man shot dead in Linstead - Jamaica Beacon","isPartOf":{"@id":"https://jamaicabeacon.com/#website"},"primaryImageOfPage":{"@id":"https://jamaicabeacon.com/linstead-news/killing-in-linstead#primaryimage"},"datePublished":"2020-02-11T10:36:06+00:00","dateModified":"2020-02-11T12:29:45+00:00","author":{"@id":"https://jamaicabeacon.com/#/schema/person/7e69d0e07503cbeff863d93f8687dcae"},"description":"The deceased is 44-year-old Neville Thomas."},{"@type":["Person"],"@id":"https://jamaicabeacon.com/#/schema/person/7e69d0e07503cbeff863d93f8687dcae","name":"Horace Mills","image":{"@type":"ImageObject","@id":"https://jamaicabeacon.com/#authorlogo","url":"https://secure.gravatar.com/avatar/dbccd12bc33f618f636f71b6ada4a670?s=96&d=mm&r=g","caption":"Horace Mills"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Jamaica Beacon &raquo; Feed" href="https://jamaicabeacon.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Jamaica Beacon &raquo; Comments Feed" href="https://jamaicabeacon.com/comments/feed" />
<link rel="alternate" type="text/calendar" title="Jamaica Beacon &raquo; iCal Feed" href="https://jamaicabeacon.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Jamaica Beacon &raquo; Man shot dead in Linstead Comments Feed" href="https://jamaicabeacon.com/linstead-news/killing-in-linstead/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/jamaicabeacon.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.2"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='tribe-common-skeleton-style-css'  href='https://jamaicabeacon.com/wp-content/plugins/the-events-calendar/common/src/resources/css/common-skeleton.min.css?ver=4.11.0' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-tooltip-css'  href='https://jamaicabeacon.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=4.11.0' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://jamaicabeacon.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.2' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='contact-form-7-css'  href='https://jamaicabeacon.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.1.6' type='text/css' media='all' />
<link rel='stylesheet' id='my-html-posts-style-file-css'  href='https://jamaicabeacon.com/wp-content/plugins/my-html-post-widgets/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='pencisc-css'  href='https://jamaicabeacon.com/wp-content/plugins/penci-framework/assets/css/single-shortcode.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='penci-oswald-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='rs-plugin-settings-css'  href='https://jamaicabeacon.com/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.4.7.4' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='colormag_google_fonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400%2C600&#038;ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='colormag_style-css'  href='https://jamaicabeacon.com/wp-content/themes/colormag/style.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='colormag-fontawesome-css'  href='https://jamaicabeacon.com/wp-content/themes/colormag/fontawesome/css/font-awesome.css?ver=4.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-lazyloadxt-spinner-css-css'  href='//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/css/jquery.lazyloadxt.spinner.css?ver=5.3.2' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://jamaicabeacon.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://jamaicabeacon.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.1.1' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript'>
/* <![CDATA[ */
var slide_in = {"demo_dir":"https:\/\/jamaicabeacon.com\/wp-content\/plugins\/convertplug\/modules\/slide_in\/assets\/demos"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctPublic = {"_ajax_nonce":"df3c50e3cf","_ajax_url":"https:\/\/jamaicabeacon.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/cleantalk-spam-protect/js/apbct-public.min.js?ver=5.133'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctNocache = {"ajaxurl":"https:\/\/jamaicabeacon.com\/wp-admin\/admin-ajax.php","info_flag":"","set_cookies_flag":"","blog_home":"https:\/\/jamaicabeacon.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/cleantalk-spam-protect/js/cleantalk_nocache.min.js?ver=5.133'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.4.7.4'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.4.7.4'></script>
<!--[if lte IE 8]>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/themes/colormag/js/html5shiv.min.js?ver=5.3.2'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://jamaicabeacon.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jamaicabeacon.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jamaicabeacon.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.2" />
<link rel='shortlink' href='https://wp.me/p9Y64j-5y0' />
<link rel="alternate" type="application/json+oembed" href="https://jamaicabeacon.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjamaicabeacon.com%2Flinstead-news%2Fkilling-in-linstead" />
<link rel="alternate" type="text/xml+oembed" href="https://jamaicabeacon.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjamaicabeacon.com%2Flinstead-news%2Fkilling-in-linstead&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script>
var portfolioDataJs = portfolioDataJs || [];
var penciBlocksArray=[];
var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script>
		<style type="text/css">
																										</style>
				<style type="text/css">
																																													
					</style>
		<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://jamaicabeacon.com"><link rel="https://theeventscalendar.com/" href="https://jamaicabeacon.com/wp-json/tribe/events/v1/" />
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="pingback" href="https://jamaicabeacon.com/xmlrpc.php">      <meta name="onesignal" content="wordpress-plugin"/>
            <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://jamaicabeacon.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'e4ef99b3-2bed-4e97-9895-950d2d6acb2b';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://jamaicabeacon.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.5136aa20-d33c-4de6-8d7f-c3f8c4b264dc";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #d3d3d3; }
</style>
	<link rel="amphtml" href="https://jamaicabeacon.com/amp/linstead-news/killing-in-linstead" /><meta name="generator" content="Powered by Slider Revolution 5.4.7.4 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-5672174960861627",
          enable_page_level_ads: true
     });
</script>
<meta name="google-site-verification" content="fBkQ4Z8ulDjzl9XCrHhGuetVvp2gULSSpn4N6Y5HDF8" />
<meta name="google-site-verification" content="fBkQ4Z8ulDjzl9XCrHhGuetVvp2gULSSpn4N6Y5HDF8" />

<script type="text/javascript" src="//newsharecounts.s3-us-west-2.amazonaws.com/nsc.js"></script><script type="text/javascript">window.newShareCountsAuto="smart";</script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-120607568-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-120607568-1');
</script>


<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
 
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/76557622/JamaicaBeacon', [[468, 60], [300, 600], [970, 90], [320, 50], [336, 280], [728, 90]], 'div-gpt-ad-1554043141894-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script data-ad-client="ca-pub-4649723253397503" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<link rel="icon" href="https://jamaicabeacon.com/wp-content/uploads/2019/09/cropped-Logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://jamaicabeacon.com/wp-content/uploads/2019/09/cropped-Logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://jamaicabeacon.com/wp-content/uploads/2019/09/cropped-Logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://jamaicabeacon.com/wp-content/uploads/2019/09/cropped-Logo-1-270x270.png" />
<script type="text/javascript">function setREVStartSize(e){									
						try{ e.c=jQuery(e.c);var i=jQuery(window).width(),t=9999,r=0,n=0,l=0,f=0,s=0,h=0;
							if(e.responsiveLevels&&(jQuery.each(e.responsiveLevels,function(e,f){f>i&&(t=r=f,l=e),i>f&&f>r&&(r=f,n=e)}),t>r&&(l=n)),f=e.gridheight[l]||e.gridheight[0]||e.gridheight,s=e.gridwidth[l]||e.gridwidth[0]||e.gridwidth,h=i/s,h=h>1?1:h,f=Math.round(h*f),"fullscreen"==e.sliderLayout){var u=(e.c.width(),jQuery(window).height());if(void 0!=e.fullScreenOffsetContainer){var c=e.fullScreenOffsetContainer.split(",");if (c) jQuery.each(c,function(e,i){u=jQuery(i).length>0?u-jQuery(i).outerHeight(!0):u}),e.fullScreenOffset.split("%").length>1&&void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0?u-=jQuery(window).height()*parseInt(e.fullScreenOffset,0)/100:void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0&&(u-=parseInt(e.fullScreenOffset,0))}f=u}else void 0!=e.minHeight&&f<e.minHeight&&(f=e.minHeight);e.c.closest(".rev_slider_wrapper").css({height:f})					
						}catch(d){console.log("Failure at Presize of Slider:"+d)}						
					};</script>
			<style type="text/css" id="wp-custom-css">
				body.blog .byline,
body.blog .tag-links,
body article .byline,
body article .tag-links
{
	display: none;
}

body article .article-content p {
	font-size: 18px;
}

body.blog .entry-title,
body article .article-content h1 {
	font-weight: bold;
	font-family: -apple-system, BlinkMacSystemFont, "Segoe UI", "Roboto", "Oxygen", "Ubuntu", "Cantarell", "Fira Sans", "Droid Sans", "Helvetica Neue", sans-serif;
}			</style>
		<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body data-rsssl=1 class="post-template-default single single-post postid-21328 single-format-standard custom-background wp-custom-logo tribe-no-js  wide wpb-js-composer js-comp-ver-6.1 vc_responsive">




<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#main">Skip to content</a>

	
	
	<header id="masthead" class="site-header clearfix ">
		<div id="header-text-nav-container" class="clearfix">

						<div class="news-bar">
				<div class="inner-wrap clearfix">
					
					
									</div>
			</div>
		
			
			
		<div class="inner-wrap">

			<div id="header-text-nav-wrap" class="clearfix">
				<div id="header-left-section">
											<div id="header-logo-image">
							<a href="https://jamaicabeacon.com/" class="custom-logo-link" rel="home"><img width="400" height="142" src="https://jamaicabeacon.com/wp-content/uploads/2019/09/cropped-Logo.png" class="custom-logo" alt="Jamaica Beacon" srcset="https://jamaicabeacon.com/wp-content/uploads/2019/09/cropped-Logo.png 400w, https://jamaicabeacon.com/wp-content/uploads/2019/09/cropped-Logo-300x107.png 300w" sizes="(max-width: 400px) 100vw, 400px" /></a>						</div><!-- #header-logo-image -->
											<div id="header-text" class="screen-reader-text">
													<h3 id="site-title">
								<a href="https://jamaicabeacon.com/" title="Jamaica Beacon" rel="home">Jamaica Beacon</a>
							</h3>
																		<p id="site-description">The home of success</p>
						<!-- #site-description -->
					</div><!-- #header-text -->
				</div><!-- #header-left-section -->
				<div id="header-right-section">
									</div><!-- #header-right-section -->

			</div><!-- #header-text-nav-wrap -->

		</div><!-- .inner-wrap -->

		
			
			
		<nav id="site-navigation" class="main-navigation clearfix" role="navigation">
			<div class="inner-wrap clearfix">
				
				
				<p class="menu-toggle"></p>
				<div class="menu-primary-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-21006" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-21006"><a href="https://jamaicabeacon.com">Home</a></li>
<li id="menu-item-21033" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21033"><a href="https://jamaicabeacon.com/category/beacon-of-the-day">BEACON OF THE DAY</a></li>
<li id="menu-item-9791" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9791"><a href="https://jamaicabeacon.com/category/large-abroad">DIASPORA</a></li>
<li id="menu-item-7251" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-7251"><a href="https://jamaicabeacon.com/category/news">NEWS</a></li>
<li id="menu-item-21204" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-21204"><a href="https://jamaicabeacon.com/category/latest-obituary">LATEST OBITUARY</a></li>
<li id="menu-item-8538" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-8538"><a href="https://jamaicabeacon.com/category/young-and-gifted">YOUNG and GIFTED</a></li>
<li id="menu-item-19714" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-19714"><a href="https://jamaicabeacon.com/category/community-focus">COMMUNITY FOCUS</a></li>
</ul></div>
			</div>
		</nav>

		
		</div><!-- #header-text-nav-container -->

		
	</header>

		
	<div id="main" class="clearfix">
		<div class="inner-wrap clearfix">

	
	<div id="primary">
		<div id="content" class="clearfix">

			
				
<article id="post-21328" class="post-21328 post type-post status-publish format-standard has-post-thumbnail hentry category-linstead-news category-news tag-murder tag-neville-thomas">
	
   
         <div class="featured-image">
               <img width="621" height="445" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2019/03/police-1.jpg" class="lazy lazy-hidden attachment-colormag-featured-image size-colormag-featured-image wp-post-image" alt="" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2019/03/police-1.jpg 800w, https://jamaicabeacon.com/wp-content/uploads/2019/03/police-1-300x215.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2019/03/police-1-768x550.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2019/03/police-1-558x400.jpg 558w, https://jamaicabeacon.com/wp-content/uploads/2019/03/police-1-585x419.jpg 585w" sizes="(max-width: 621px) 100vw, 621px" /><noscript><img width="621" height="445" src="https://jamaicabeacon.com/wp-content/uploads/2019/03/police-1.jpg" class="attachment-colormag-featured-image size-colormag-featured-image wp-post-image" alt="" srcset="https://jamaicabeacon.com/wp-content/uploads/2019/03/police-1.jpg 800w, https://jamaicabeacon.com/wp-content/uploads/2019/03/police-1-300x215.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2019/03/police-1-768x550.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2019/03/police-1-558x400.jpg 558w, https://jamaicabeacon.com/wp-content/uploads/2019/03/police-1-585x419.jpg 585w" sizes="(max-width: 621px) 100vw, 621px" /></noscript>            </div>
   
   <div class="article-content clearfix">

   
   <div class="above-entry-meta"><span class="cat-links"><a href="https://jamaicabeacon.com/category/linstead-news"  rel="category tag">LINSTEAD</a>&nbsp;<a href="https://jamaicabeacon.com/category/news"  rel="category tag">NEWS</a>&nbsp;</span></div>
      <header class="entry-header">
   		<h1 class="entry-title">
   			Man shot dead in Linstead   		</h1>
   	</header>

   	<div class="below-entry-meta">
			<span class="posted-on"><a href="https://jamaicabeacon.com/linstead-news/killing-in-linstead" title="5:36 am" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2020-02-11T05:36:06-05:00">February 11, 2020</time><time class="updated" datetime="2020-02-11T07:29:45-05:00">February 11, 2020</time></a></span>
			<span class="byline">
				<span class="author vcard">
					<i class="fa fa-user"></i>
					<a class="url fn n"
					   href="https://jamaicabeacon.com/author/horacemills"
					   title="Horace Mills">Horace Mills					</a>
				</span>
			</span>

							<span class="comments"><a href="https://jamaicabeacon.com/linstead-news/killing-in-linstead#respond"><span class="dsq-postid" data-dsqidentifier="21328 https://jamaicabeacon.com/?p=21328"><i class="fa fa-comment"></i> 0 Comments</span></a></span>
			<span class="tag-links"><i class="fa fa-tags"></i><a href="https://jamaicabeacon.com/tag/murder" rel="tag">murder</a>, <a href="https://jamaicabeacon.com/tag/neville-thomas" rel="tag">Neville Thomas</a></span></div>
   	<div class="entry-content clearfix">
   		<div class="addtoany_share_save_container addtoany_content addtoany_content_top"><div class="a2a_kit a2a_kit_size_34 addtoany_list" data-a2a-url="https://jamaicabeacon.com/linstead-news/killing-in-linstead" data-a2a-title="Man shot dead in Linstead"><a class="a2a_button_facebook a2a_counter" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fjamaicabeacon.com%2Flinstead-news%2Fkilling-in-linstead&amp;linkname=Man%20shot%20dead%20in%20Linstead" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fjamaicabeacon.com%2Flinstead-news%2Fkilling-in-linstead&amp;linkname=Man%20shot%20dead%20in%20Linstead" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=https%3A%2F%2Fjamaicabeacon.com%2Flinstead-news%2Fkilling-in-linstead&amp;linkname=Man%20shot%20dead%20in%20Linstead" title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fjamaicabeacon.com%2Flinstead-news%2Fkilling-in-linstead&amp;linkname=Man%20shot%20dead%20in%20Linstead" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook_messenger" href="https://www.addtoany.com/add_to/facebook_messenger?linkurl=https%3A%2F%2Fjamaicabeacon.com%2Flinstead-news%2Fkilling-in-linstead&amp;linkname=Man%20shot%20dead%20in%20Linstead" title="Facebook Messenger" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div>
<p>The Jamaica Constabulary Force (JCF) has confirmed that a man was shot and killed in the Wakefield area of Linstead, St. Catherine, last evening, February 10.<br></p>



<p>The deceased is 44-year-old Neville Thomas.<br></p>



<p>According to the JCF, residents alerted its officers after hearing explosions about 7:35PM at Lady Bird Lane in Wakefield.<br></p>



<p>When the cops arrived, they found Thomas with a gunshot wound to the chest, the JCF further told <strong>The Beacon.</strong><br></p>



<p>Photos of the crime scene show Thomas, attired in blue shirt and black pants with white stripe, lying on his back on the ground.</p>
<span class="cp-load-after-post"></span><hr>
<p>Please send us news, classifieds, obituaries or advertisement via WhatsApp (876-305-4574) or email (jamaicabeaconnews@gmail.com); you can also make a donation below. </p>
<input type="image" style="cursor: pointer;" src="https://www.paypal.com/en_US/i/btn/btn_donateCC_LG.gif" name="submit" alt="PayPal - The safer, easier way to pay online."></p>   	</div>

   </div>

	</article>

			
		</div><!-- #content -->

      
		<ul class="default-wp-page clearfix">
			<li class="previous"><a href="https://jamaicabeacon.com/guys-hill/tragic-irony" rel="prev"><span class="meta-nav">&larr;</span> TRAGIC IRONY</a></li>
			<li class="next"></li>
		</ul>
	
      
      
      
<div id="disqus_thread"></div>

	</div><!-- #primary -->

	
<div id="secondary">
			
		<aside id="media_image-19" class="widget widget_media_image clearfix"><h3 class="widget-title"><span>Linstead make-up artist:</span></h3><img width="300" height="250" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2020/02/ad-makeup-artist-300x250.jpg" class="lazy lazy-hidden image wp-image-21167  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2020/02/ad-makeup-artist-300x250.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2020/02/ad-makeup-artist.jpg 400w" sizes="(max-width: 300px) 100vw, 300px" /><noscript><img width="300" height="250" src="https://jamaicabeacon.com/wp-content/uploads/2020/02/ad-makeup-artist-300x250.jpg" class="image wp-image-21167  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://jamaicabeacon.com/wp-content/uploads/2020/02/ad-makeup-artist-300x250.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2020/02/ad-makeup-artist.jpg 400w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></aside><aside id="paypal_donations-3" class="widget widget_paypal_donations clearfix"><h3 class="widget-title"><span>Donate</span></h3><p>Send us positive news, and make a donation in support of free and fair community journalism.</p>
<!-- Begin PayPal Donations by https://www.tipsandtricks-hq.com/paypal-donations-widgets-plugin -->

<form action="https://www.paypal.com/cgi-bin/webscr" method="post">
    <div class="paypal-donations">
        <input type="hidden" name="cmd" value="_donations" />
        <input type="hidden" name="bn" value="TipsandTricks_SP" />
        <input type="hidden" name="business" value="jamaicabeaconnews@gmail.com" />
        <input type="hidden" name="rm" value="0" />
        <input type="hidden" name="currency_code" value="USD" />
        <input type="image" style="cursor: pointer;" src="https://www.paypal.com/en_US/i/btn/btn_donateCC_LG.gif" name="submit" alt="PayPal - The safer, easier way to pay online." />
        <img class="lazy lazy-hidden" alt="" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1" /><noscript><img alt="" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1" /></noscript>
    </div>
</form>
<!-- End PayPal Donations -->
</aside>
	</div>
	

</div><!-- .inner-wrap -->
</div><!-- #main -->




<footer id="colophon" class="clearfix ">
	
	<div class="footer-socket-wrapper clearfix">
		<div class="inner-wrap">
			<div class="footer-socket-area">
				<div class="footer-socket-right-section">
							<div class="social-links clearfix">
			<ul>
				<li><a href="https://www.facebook.com/JamaicaBeacon" ><i class="fa fa-facebook"></i></a></li><li><a href="https://twitter.com/BeaconJamaica" ><i class="fa fa-twitter"></i></a></li><li><a href="https://www.instagram.com/jamaicabeaconnews" ><i class="fa fa-instagram"></i></a></li>			</ul>
		</div><!-- .social-links -->
						</div>

				<div class="footer-socket-left-section">
										<p style="width: 40%; color: #f2f2f2">
						The stories and graphics presented on JamaicaBeacon.com are copyrighted as collective work, and, other than for personal use, shall not be reproduced or used without written permission from JamaicaBeacon.com.
					</p>
					<p style="width: 25%; color: #f2f2f2">
						Don't hesitate. Support positive journalism today. Donate to The Beacon.
					</p>
					<input type="image" style="cursor: pointer;" src="https://www.paypal.com/en_US/i/btn/btn_donateCC_LG.gif" name="submit" alt="PayPal - The safer, easier way to pay online.">
				</div>
			</div>
		</div>
	</div>
</footer>

<a href="#masthead" id="scroll-up"><i class="fa fa-chevron-up"></i></a>

</div><!-- #page -->
				<script type="text/javascript" id="modal">
					jQuery(window).on( 'load', function(){
						startclock();
					});
					function stopclock (){
						if(timerRunning) clearTimeout(timerID);
						timerRunning = false;
						document.cookie="time=0";
					}
					function showtime () {
						var now = new Date();
						var my = now.getTime() ;
						now = new Date(my-diffms) ;
						document.cookie="time="+now.toLocaleString();
						timerID = setTimeout('showtime()',10000);
						timerRunning = true;
					}
					function startclock () {
						stopclock();
						showtime();
					}
					var timerID = null;
					var timerRunning = false;
					var x = new Date() ;
					var now = x.getTime() ;
					var gmt = 1581457565 * 1000 ;
					var diffms = (now - gmt) ;
				</script>
								<script type="text/javascript" id="info-bar">
					jQuery(window).on( 'load', function(){
						startclock();
					});
					function stopclock (){
						if(timerRunning) clearTimeout(timerID);
						timerRunning = false;
						document.cookie="time=0";
					}
					function showtime () {
						var now = new Date();
						var my = now.getTime() ;
						now = new Date(my-diffms) ;
						document.cookie="time="+now.toLocaleString();
						timerID = setTimeout('showtime()',10000);
						timerRunning = true;
					}
					function startclock () {
						stopclock();
						showtime();
					}
					var timerID = null;
					var timerRunning = false;
					var x = new Date() ;
					var now = x.getTime() ;
					var gmt = 1581457565 * 1000 ;
					var diffms = (now - gmt) ;
				</script>
								<script type="text/javascript" id="slidein">
					jQuery(window).on( 'load', function(){
						startclock();
					});
					function stopclock (){
						if(timerRunning) clearTimeout(timerID);
						timerRunning = false;
						document.cookie="time=0";
					}

					function showtime () {
						var now = new Date();
						var my = now.getTime() ;
						now = new Date(my-diffms) ;
						document.cookie="time="+now.toLocaleString();
						timerID = setTimeout('showtime()',10000);
						timerRunning = true;
					}

					function startclock () {
						stopclock();
						showtime();
					}
					var timerID = null;
					var timerRunning = false;
					var x = new Date() ;
					var now = x.getTime() ;
					var gmt = 1581457565 * 1000 ;
					var diffms = (now - gmt) ;
				</script>
						<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
			<div style="display:none">
	</div>
<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/jamaicabeacon.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.1.6'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"jamaica-beacon"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"21328 https:\/\/jamaicabeacon.com\/?p=21328","disqusShortname":"jamaica-beacon","disqusTitle":"Man shot dead in Linstead","disqusUrl":"https:\/\/jamaicabeacon.com\/linstead-news\/killing-in-linstead","postId":"21328"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/penci-pennews-recipe/js/jquery.rateyo.min.js?ver=2.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PENCI = {"ajaxUrl":"https:\/\/jamaicabeacon.com\/wp-admin\/admin-ajax.php","nonce":"1e59979a9f","normalFill":"#b9b9b9","ratedFill":"#FFCA00"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/penci-pennews-recipe/js/rating_recipe.js?ver=2.3.2'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/penci-pennews-review/js/jquery.easypiechart.min.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PENCI = {"postID":"21328","ajaxUrl":"https:\/\/jamaicabeacon.com\/wp-admin\/admin-ajax.php","nonce":"1e59979a9f","normalFill":"#b9b9b9","ratedFill":"#FFCA00"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/penci-pennews-review/js/rating_review.js?ver=3.0'></script>
<script type='text/javascript' src='https://secure.gravatar.com/js/gprofiles.js?ver=2020Febaa'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var WPGroHo = {"my_hash":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/jetpack/modules/wpgroho.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-includes/js/comment-reply.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/themes/colormag/js/jquery.bxslider.min.js?ver=4.2.10'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/themes/colormag/js/navigation.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/themes/colormag/js/fitvids/jquery.fitvids.js?ver=20150311'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/themes/colormag/js/skip-link-focus-fix.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/themes/colormag/js/colormag-custom.js?ver=5.3.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var a3_lazyload_params = {"apply_images":"1","apply_videos":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.extra.min.js?ver=2.2.2'></script>
<script type='text/javascript' src='//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.srcset.min.js?ver=2.2.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var a3_lazyload_extend_params = {"edgeY":"0"};
/* ]]> */
</script>
<script type='text/javascript' src='//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.extend.js?ver=2.2.2'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-includes/js/wp-embed.min.js?ver=5.3.2'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.3.2' async='async'></script>
<script type='text/javascript' src='https://stats.wp.com/e-202007.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.1.1',blog:'147310035',post:'21328',tz:'-5',srv:'jamaicabeacon.com'} ]);
	_stq.push([ 'clickTrackerInit', '147310035', '21328' ]);
</script>
</body>
</html>
