<!DOCTYPE html>
<html lang="en-US">
<head>
			<meta charset="UTF-8" />
		<meta name="viewport" content="width=device-width, initial-scale=1">
		<link rel="profile" href="https://gmpg.org/xfn/11" />
		<script type='text/javascript'>function ctSetCookie___from_backend(c_name, value) {document.cookie = c_name + "=" + encodeURIComponent(value) + "; path=/; samesite=lax";}ctSetCookie___from_backend('ct_checkjs', '211565131', '0');</script>
	<!-- This site is optimized with the Yoast SEO plugin v14.5 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Major Goat-stealing Ring - Bog Walk Politician Nabs Suspect, Saves Him From Mob - Jamaica Beacon</title>
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://jamaicabeacon.com/exclusive-news-stories/major-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Major Goat-stealing Ring - Bog Walk Politician Nabs Suspect, Saves Him From Mob - Jamaica Beacon" />
	<meta property="og:description" content="Written By: Sandy Burke, Jamaica Beacon writer &#8211; St Catherine Councillor for the Bog Walk Division in St Catherine, Peter" />
	<meta property="og:url" content="https://jamaicabeacon.com/exclusive-news-stories/major-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob" />
	<meta property="og:site_name" content="Jamaica Beacon" />
	<meta property="article:published_time" content="2022-03-14T16:32:03+00:00" />
	<meta property="article:modified_time" content="2022-03-14T17:11:33+00:00" />
	<meta property="og:image" content="https://jamaicabeacon.com/wp-content/uploads/2022/03/Peter-Abrahams-goat.jpg" />
	<meta property="og:image:width" content="800" />
	<meta property="og:image:height" content="536" />
	<meta name="twitter:card" content="summary_large_image" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://jamaicabeacon.com/#website","url":"https://jamaicabeacon.com/","name":"Jamaica Beacon","description":"Stories Others Missed","potentialAction":[{"@type":"SearchAction","target":"https://jamaicabeacon.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://jamaicabeacon.com/exclusive-news-stories/major-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob#primaryimage","inLanguage":"en-US","url":"https://jamaicabeacon.com/wp-content/uploads/2022/03/Peter-Abrahams-goat.jpg","width":800,"height":536,"caption":"Councillor for Bog Walk Division Peter Abrahams is pictured here as well as his goat that he said was returned this month when the thieves found out it belongs to him"},{"@type":"WebPage","@id":"https://jamaicabeacon.com/exclusive-news-stories/major-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob#webpage","url":"https://jamaicabeacon.com/exclusive-news-stories/major-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob","name":"Major Goat-stealing Ring - Bog Walk Politician Nabs Suspect, Saves Him From Mob - Jamaica Beacon","isPartOf":{"@id":"https://jamaicabeacon.com/#website"},"primaryImageOfPage":{"@id":"https://jamaicabeacon.com/exclusive-news-stories/major-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob#primaryimage"},"datePublished":"2022-03-14T16:32:03+00:00","dateModified":"2022-03-14T17:11:33+00:00","author":{"@id":"https://jamaicabeacon.com/#/schema/person/15ee172f658778651e315fb630c4d94e"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://jamaicabeacon.com/exclusive-news-stories/major-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob"]}]},{"@type":["Person"],"@id":"https://jamaicabeacon.com/#/schema/person/15ee172f658778651e315fb630c4d94e","name":"Jamaica Beacon","image":{"@type":"ImageObject","@id":"https://jamaicabeacon.com/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/1ddbc25c64eea64d62302dae69dcf4d1?s=96&d=mm&r=g","caption":"Jamaica Beacon"}}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//secure.gravatar.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Jamaica Beacon &raquo; Feed" href="https://jamaicabeacon.com/feed" />
<link rel="alternate" type="application/rss+xml" title="Jamaica Beacon &raquo; Comments Feed" href="https://jamaicabeacon.com/comments/feed" />
<link rel="alternate" type="text/calendar" title="Jamaica Beacon &raquo; iCal Feed" href="https://jamaicabeacon.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Jamaica Beacon &raquo; Major Goat-stealing Ring &#8211; Bog Walk Politician Nabs Suspect, Saves Him From Mob Comments Feed" href="https://jamaicabeacon.com/exclusive-news-stories/major-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob/feed" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/jamaicabeacon.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.12"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://jamaicabeacon.com/wp-includes/css/dist/block-library/style.min.css?ver=5.3.12' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='wp-block-library-theme-css'  href='https://jamaicabeacon.com/wp-includes/css/dist/block-library/theme.min.css?ver=5.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='contact-form-7-css'  href='https://jamaicabeacon.com/wp-content/plugins/contact-form-7/includes/css/styles.css?ver=5.2' type='text/css' media='all' />
<link rel='stylesheet' id='dashicons-css'  href='https://jamaicabeacon.com/wp-includes/css/dashicons.min.css?ver=5.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='everest-forms-general-css'  href='https://jamaicabeacon.com/wp-content/plugins/everest-forms/assets/css/everest-forms.css?ver=1.7.0.1' type='text/css' media='all' />
<link rel='stylesheet' id='my-html-posts-style-file-css'  href='https://jamaicabeacon.com/wp-content/plugins/my-html-post-widgets/style.css?ver=5.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='pencisc-css'  href='https://jamaicabeacon.com/wp-content/plugins/penci-framework/assets/css/single-shortcode.css?ver=5.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='penci-oswald-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400&#038;ver=5.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='colormag_style-css'  href='https://jamaicabeacon.com/wp-content/themes/colormag/style.css?ver=2.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='colormag-fontawesome-css'  href='https://jamaicabeacon.com/wp-content/themes/colormag/fontawesome/css/font-awesome.min.css?ver=2.0.9' type='text/css' media='all' />
<link rel='stylesheet' id='colormag_googlefonts-css'  href='//fonts.googleapis.com/css?family=Open+Sans%3A400%2C600&#038;1&#038;display=swap&#038;ver=2.0.9' type='text/css' media='all' />
<!-- Inline jetpack_facebook_likebox -->
<style id='jetpack_facebook_likebox-inline-css' type='text/css'>
.widget_facebook_likebox {
	overflow: hidden;
}

</style>
<link rel='stylesheet' id='jquery-lazyloadxt-spinner-css-css'  href='//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/css/jquery.lazyloadxt.spinner.css?ver=5.3.12' type='text/css' media='all' />
<link rel='stylesheet' id='addtoany-css'  href='https://jamaicabeacon.com/wp-content/plugins/add-to-any/addtoany.min.css?ver=1.15' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://jamaicabeacon.com/wp-content/plugins/jetpack/css/jetpack.css?ver=8.7.2' type='text/css' media='all' />
<script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript'>
/* <![CDATA[ */
var slide_in = {"demo_dir":"https:\/\/jamaicabeacon.com\/wp-content\/plugins\/convertplug\/modules\/slide_in\/assets\/demos"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/add-to-any/addtoany.min.js?ver=1.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctPublic = {"_ajax_nonce":"cee9e4e944","_ajax_url":"https:\/\/jamaicabeacon.com\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/cleantalk-spam-protect/js/apbct-public.min.js?ver=5.141.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ctNocache = {"ajaxurl":"https:\/\/jamaicabeacon.com\/wp-admin\/admin-ajax.php","info_flag":"","set_cookies_flag":"","blog_home":"https:\/\/jamaicabeacon.com\/"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/cleantalk-spam-protect/js/cleantalk_nocache.min.js?ver=5.141.3'></script>
<!--[if lte IE 8]>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/themes/colormag/js/html5shiv.min.js?ver=2.0.9'></script>
<![endif]-->
<link rel='https://api.w.org/' href='https://jamaicabeacon.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://jamaicabeacon.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://jamaicabeacon.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.3.12" />
<meta name="generator" content="Everest Forms 1.7.0.1" />
<link rel='shortlink' href='https://wp.me/p9Y64j-8Xk' />
<link rel="alternate" type="application/json+oembed" href="https://jamaicabeacon.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjamaicabeacon.com%2Fexclusive-news-stories%2Fmajor-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob" />
<link rel="alternate" type="text/xml+oembed" href="https://jamaicabeacon.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fjamaicabeacon.com%2Fexclusive-news-stories%2Fmajor-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob&#038;format=xml" />

<script data-cfasync="false">
window.a2a_config=window.a2a_config||{};a2a_config.callbacks=[];a2a_config.overlays=[];a2a_config.templates={};
(function(d,s,a,b){a=d.createElement(s);b=d.getElementsByTagName(s)[0];a.async=1;a.src="https://static.addtoany.com/menu/page.js";b.parentNode.insertBefore(a,b);})(document,"script");
</script>
<script>
var portfolioDataJs = portfolioDataJs || [];
var penciBlocksArray=[];
var PENCILOCALCACHE = {};
		(function () {
				"use strict";
		
				PENCILOCALCACHE = {
					data: {},
					remove: function ( ajaxFilterItem ) {
						delete PENCILOCALCACHE.data[ajaxFilterItem];
					},
					exist: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data.hasOwnProperty( ajaxFilterItem ) && PENCILOCALCACHE.data[ajaxFilterItem] !== null;
					},
					get: function ( ajaxFilterItem ) {
						return PENCILOCALCACHE.data[ajaxFilterItem];
					},
					set: function ( ajaxFilterItem, cachedData ) {
						PENCILOCALCACHE.remove( ajaxFilterItem );
						PENCILOCALCACHE.data[ajaxFilterItem] = cachedData;
					}
				};
			}
		)();function penciBlock() {
		    this.atts_json = '';
		    this.content = '';
		}</script>
		<style type="text/css">
																										</style>
				<style type="text/css">
																																													
					</style>
		<!-- <meta name="NextGEN" version="2.2.33" /> -->
<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://jamaicabeacon.com"><link rel="https://theeventscalendar.com/" href="https://jamaicabeacon.com/wp-json/tribe/events/v1/" /><style type="text/css" media="screen">input#akismet_privacy_check { float: left; margin: 7px 7px 7px 0; width: 13px; }</style>
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<style type='text/css'>img#wpstats{display:none}</style><link rel="pingback" href="https://jamaicabeacon.com/xmlrpc.php">      <meta name="onesignal" content="wordpress-plugin"/>
            <script>

      window.OneSignal = window.OneSignal || [];

      OneSignal.push( function() {
        OneSignal.SERVICE_WORKER_UPDATER_PATH = "OneSignalSDKUpdaterWorker.js.php";
        OneSignal.SERVICE_WORKER_PATH = "OneSignalSDKWorker.js.php";
        OneSignal.SERVICE_WORKER_PARAM = { scope: '/' };

        OneSignal.setDefaultNotificationUrl("https://jamaicabeacon.com");
        var oneSignal_options = {};
        window._oneSignalInitOptions = oneSignal_options;

        oneSignal_options['wordpress'] = true;
oneSignal_options['appId'] = 'e4ef99b3-2bed-4e97-9895-950d2d6acb2b';
oneSignal_options['welcomeNotification'] = { };
oneSignal_options['welcomeNotification']['disable'] = true;
oneSignal_options['path'] = "https://jamaicabeacon.com/wp-content/plugins/onesignal-free-web-push-notifications/sdk_files/";
oneSignal_options['safari_web_id'] = "web.onesignal.auto.5136aa20-d33c-4de6-8d7f-c3f8c4b264dc";
oneSignal_options['persistNotification'] = true;
oneSignal_options['promptOptions'] = { };
                OneSignal.init(window._oneSignalInitOptions);
                OneSignal.showSlidedownPrompt();      });

      function documentInitOneSignal() {
        var oneSignal_elements = document.getElementsByClassName("OneSignal-prompt");

        var oneSignalLinkClickHandler = function(event) { OneSignal.push(['registerForPushNotifications']); event.preventDefault(); };        for(var i = 0; i < oneSignal_elements.length; i++)
          oneSignal_elements[i].addEventListener('click', oneSignalLinkClickHandler, false);
      }

      if (document.readyState === 'complete') {
           documentInitOneSignal();
      }
      else {
           window.addEventListener("load", function(event){
               documentInitOneSignal();
          });
      }
    </script>
<meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/>
<style type="text/css">.broken_link, a.broken_link {
	text-decoration: line-through;
}</style><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #d3d3d3; }
</style>
	<link rel="amphtml" href="https://jamaicabeacon.com/amp/exclusive-news-stories/major-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob" /><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({
          google_ad_client: "ca-pub-5672174960861627",
          enable_page_level_ads: true
     });
</script>
<meta name="google-site-verification" content="fBkQ4Z8ulDjzl9XCrHhGuetVvp2gULSSpn4N6Y5HDF8" />
<meta name="google-site-verification" content="fBkQ4Z8ulDjzl9XCrHhGuetVvp2gULSSpn4N6Y5HDF8" />

<script type="text/javascript" src="//newsharecounts.s3-us-west-2.amazonaws.com/nsc.js"></script><script type="text/javascript">window.newShareCountsAuto="smart";</script>
<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-120607568-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-120607568-1');
</script>


<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>
 
<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/76557622/JamaicaBeacon', [[468, 60], [300, 600], [970, 90], [320, 50], [336, 280], [728, 90]], 'div-gpt-ad-1554043141894-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script data-ad-client="ca-pub-4649723253397503" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<link rel="icon" href="https://jamaicabeacon.com/wp-content/uploads/2019/09/cropped-Logo-1-32x32.png" sizes="32x32" />
<link rel="icon" href="https://jamaicabeacon.com/wp-content/uploads/2019/09/cropped-Logo-1-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://jamaicabeacon.com/wp-content/uploads/2019/09/cropped-Logo-1-180x180.png" />
<meta name="msapplication-TileImage" content="https://jamaicabeacon.com/wp-content/uploads/2019/09/cropped-Logo-1-270x270.png" />
			<style type="text/css" id="wp-custom-css">
				body.blog .byline,
body.blog .tag-links,
body article .byline,
body article .tag-links
{
	display: none;
}

body article .article-content p {
	font-size: 18px;
}

body.blog .entry-title,
body article .article-content h1 {
	font-weight: bold;
	font-family: -apple-system, BlinkMacSystemFont, "Segoe UI", "Roboto", "Oxygen", "Ubuntu", "Cantarell", "Fira Sans", "Droid Sans", "Helvetica Neue", sans-serif;
}			</style>
		<noscript><style> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript><style>
.ai-viewports                 {--ai: 1;}
.ai-viewport-3                { display: none !important;}
.ai-viewport-2                { display: none !important;}
.ai-viewport-1                { display: inherit !important;}
.ai-viewport-0                { display: none !important;}
@media (min-width: 768px) and (max-width: 979px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-2                { display: inherit !important;}
}
@media (max-width: 767px) {
.ai-viewport-1                { display: none !important;}
.ai-viewport-3                { display: inherit !important;}
}
</style>
<link rel='stylesheet' id='mediaelement-css'  href='https://jamaicabeacon.com/wp-includes/js/mediaelement/mediaelementplayer-legacy.min.css?ver=4.2.13-9993131' type='text/css' media='all' />
<link rel='stylesheet' id='wp-mediaelement-css'  href='https://jamaicabeacon.com/wp-includes/js/mediaelement/wp-mediaelement.min.css?ver=5.3.12' type='text/css' media='all' />
</head>

<body data-rsssl=1 class="post-template-default single single-post postid-34430 single-format-standard custom-background wp-custom-logo wp-embed-responsive everest-forms-no-js tribe-no-js right-sidebar wide wpb-js-composer js-comp-ver-6.1 vc_responsive">


		<div id="page" class="hfeed site">
				<a class="skip-link screen-reader-text" href="#main">Skip to content</a>
				<header id="masthead" class="site-header clearfix ">
				<div id="header-text-nav-container" class="clearfix">
		
			<div class="news-bar">
				<div class="inner-wrap clearfix">
					
		<div class="social-links clearfix">
			<ul>
				<li><a href="https://www.facebook.com/JamaicaBeacon" ><i class="fa fa-facebook"></i></a></li><li><a href="https://twitter.com/BeaconJamaica" ><i class="fa fa-twitter"></i></a></li><li><a href="https://www.instagram.com/jamaicabeaconnews" ><i class="fa fa-instagram"></i></a></li><li><a href="https://www.youtube.com/channel/UCVgr2P9uomLurrQlKrY7MFg?view_as=subscriber" ><i class="fa fa-youtube"></i></a></li>			</ul>
		</div><!-- .social-links -->
						</div>
			</div>

			
		<div class="inner-wrap">
			<div id="header-text-nav-wrap" class="clearfix">

				<div id="header-left-section">
											<div id="header-logo-image">
							<a href="https://jamaicabeacon.com/" class="custom-logo-link" rel="home"><img width="400" height="142" src="https://jamaicabeacon.com/wp-content/uploads/2019/09/cropped-Logo.png" class="custom-logo" alt="Jamaica Beacon" srcset="https://jamaicabeacon.com/wp-content/uploads/2019/09/cropped-Logo.png 400w, https://jamaicabeacon.com/wp-content/uploads/2019/09/cropped-Logo-300x107.png 300w" sizes="(max-width: 400px) 100vw, 400px" /></a>						</div><!-- #header-logo-image -->
						
					<div id="header-text" class="screen-reader-text">
													<h3 id="site-title">
								<a href="https://jamaicabeacon.com/" title="Jamaica Beacon" rel="home">Jamaica Beacon</a>
							</h3>
						
													<p id="site-description">
								Stories Others Missed							</p><!-- #site-description -->
											</div><!-- #header-text -->
				</div><!-- #header-left-section -->

				<div id="header-right-section">
											<div id="header-right-sidebar" class="clearfix">
							<aside id="colormag_125x125_advertisement_widget-2" class="widget widget_125x125_advertisement clearfix">
		<div class="advertisement_125x125">
			<div class="advertisement-content"><a href="https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD.jpg" class="single_ad_125x125" target="_blank" rel="nofollow"><img class="lazy lazy-hidden" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD.jpg" width="125" height="125" alt=""><noscript><img src="https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD.jpg" width="125" height="125" alt=""></noscript></a><a href="https://jamaicabeacon.com/wp-content/uploads/2022/02/Kids-Store.jpg" class="single_ad_125x125" target="_blank" rel="nofollow"><img class="lazy lazy-hidden" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/02/Kids-Store.jpg" width="125" height="125" alt=""><noscript><img src="https://jamaicabeacon.com/wp-content/uploads/2022/02/Kids-Store.jpg" width="125" height="125" alt=""></noscript></a><a href="https://breadandbutterexpress.com/" class="single_ad_125x125" target="_blank" rel="nofollow"><img class="lazy lazy-hidden" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2021/10/Bread-and-Butter-Express-ad.jpg" width="125" height="125" alt=""><noscript><img src="https://jamaicabeacon.com/wp-content/uploads/2021/10/Bread-and-Butter-Express-ad.jpg" width="125" height="125" alt=""></noscript></a><a href="https://jamaicabeacon.com/wp-content/uploads/2022/03/Absolute-Care-1.jpg" class="single_ad_125x125" target="_blank" rel="nofollow"><img class="lazy lazy-hidden" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Absolute-Care-1.jpg" width="125" height="125" alt=""><noscript><img src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Absolute-Care-1.jpg" width="125" height="125" alt=""></noscript></a><a href="https://jamaicabeacon.com/wp-content/uploads/2022/03/Renew-March-ad.jpg" class="single_ad_125x125" target="_blank" rel="nofollow"><img class="lazy lazy-hidden" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Renew-March-ad.jpg" width="125" height="125" alt=""><noscript><img src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Renew-March-ad.jpg" width="125" height="125" alt=""></noscript></a><a href="https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3.jpg" class="single_ad_125x125" target="_blank" rel="nofollow"><img class="lazy lazy-hidden" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3.jpg" width="125" height="125" alt=""><noscript><img src="https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3.jpg" width="125" height="125" alt=""></noscript></a></div>		</div>

		</aside><aside id="media_image-54" class="widget widget_media_image clearfix"><a href="https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home.jpg"><img width="900" height="450" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home.jpg" class="lazy lazy-hidden image wp-image-34233  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home.jpg 900w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home-300x150.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home-768x384.jpg 768w" sizes="(max-width: 900px) 100vw, 900px" /><noscript><img width="900" height="450" src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home.jpg" class="image wp-image-34233  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home.jpg 900w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home-300x150.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home-768x384.jpg 768w" sizes="(max-width: 900px) 100vw, 900px" /></noscript></a></aside><aside id="media_image-56" class="widget widget_media_image clearfix"><a href="https://jamaicabeacon.com/wp-content/uploads/2022/03/advertise-here.jpg"><img width="900" height="500" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/03/advertise-here.jpg" class="lazy lazy-hidden image wp-image-34408  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2022/03/advertise-here.jpg 900w, https://jamaicabeacon.com/wp-content/uploads/2022/03/advertise-here-300x167.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/03/advertise-here-768x427.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2022/03/advertise-here-800x445.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" /><noscript><img width="900" height="500" src="https://jamaicabeacon.com/wp-content/uploads/2022/03/advertise-here.jpg" class="image wp-image-34408  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://jamaicabeacon.com/wp-content/uploads/2022/03/advertise-here.jpg 900w, https://jamaicabeacon.com/wp-content/uploads/2022/03/advertise-here-300x167.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/03/advertise-here-768x427.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2022/03/advertise-here-800x445.jpg 800w" sizes="(max-width: 900px) 100vw, 900px" /></noscript></a></aside>						</div>
										</div><!-- #header-right-section -->

			</div><!-- #header-text-nav-wrap -->
		</div><!-- .inner-wrap -->

		
		<nav id="site-navigation" class="main-navigation clearfix" role="navigation">
			<div class="inner-wrap clearfix">
				
				
				<p class="menu-toggle"></p>
				<div class="menu-primary-container"><ul id="menu-topbar-menu" class="menu"><li id="menu-item-33796" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-33796"><a href="https://jamaicabeacon.com/category/beacon-of-the-day">BEACON OF THE DAY</a>
<ul class="sub-menu">
	<li id="menu-item-34078" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34078"><a href="https://jamaicabeacon.com/category/academics">ACADEMICS</a></li>
	<li id="menu-item-34080" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34080"><a href="https://jamaicabeacon.com/category/heroism">HEROISM</a></li>
	<li id="menu-item-34166" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34166"><a href="https://jamaicabeacon.com/category/business">BUSINESS</a></li>
	<li id="menu-item-34172" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34172"><a href="https://jamaicabeacon.com/category/health">HEALTH</a></li>
	<li id="menu-item-34079" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34079"><a href="https://jamaicabeacon.com/category/community-service">COMMUNITY SERVICE</a></li>
	<li id="menu-item-34168" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34168"><a href="https://jamaicabeacon.com/category/sports">SPORTS</a></li>
	<li id="menu-item-34169" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34169"><a href="https://jamaicabeacon.com/category/entertainment">ENTERTAINMENT</a></li>
	<li id="menu-item-34084" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34084"><a href="https://jamaicabeacon.com/category/awards">AWARDS</a></li>
	<li id="menu-item-34372" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34372"><a href="https://jamaicabeacon.com/category/leadership">LEADERSHIP</a></li>
</ul>
</li>
<li id="menu-item-34094" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-34094"><a href="https://jamaicabeacon.com/category/linstead-news">LINSTEAD</a></li>
<li id="menu-item-34025" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-34025"><a href="https://jamaicabeacon.com/category/news">NEWS</a>
<ul class="sub-menu">
	<li id="menu-item-33811" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-33811"><a href="https://jamaicabeacon.com/category/news-exclusives">NEWS EXCLUSIVES</a></li>
</ul>
</li>
<li id="menu-item-34244" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34244"><a href="https://jamaicabeacon.com/category/obituaries">OBITUARIES</a></li>
<li id="menu-item-34242" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-34242"><a href="https://jamaicabeacon.com/category/events">EVENTS</a>
<ul class="sub-menu">
	<li id="menu-item-34031" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34031"><a href="https://jamaicabeacon.com/category/birthdays">BIRTHDAYS</a></li>
	<li id="menu-item-34245" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34245"><a href="https://jamaicabeacon.com/category/weddings">WEDDINGS</a></li>
	<li id="menu-item-34243" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34243"><a href="https://jamaicabeacon.com/category/funerals">FUNERALS</a></li>
</ul>
</li>
<li id="menu-item-34249" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-34249"><a href="https://jamaicabeacon.com/category/classifieds">CLASSIFIEDS</a></li>
</ul></div>
			</div>
		</nav>

				</div><!-- #header-text-nav-container -->
				</header><!-- #masthead -->
				<div id="main" class="clearfix">
				<div class="inner-wrap clearfix">
		
	<div id="primary">
		<div id="content" class="clearfix">

			
<article id="post-34430" class="post-34430 post type-post status-publish format-standard hentry category-exclusive-news-stories category-linstead-news category-news">
	
	
	<div class="article-content clearfix">

		<div class="above-entry-meta"><span class="cat-links"><a href="https://jamaicabeacon.com/category/exclusive-news-stories"  rel="category tag">EXCLUSIVE NEWS STORIES</a>&nbsp;<a href="https://jamaicabeacon.com/category/linstead-news"  rel="category tag">LINSTEAD</a>&nbsp;<a href="https://jamaicabeacon.com/category/news"  rel="category tag">NEWS</a>&nbsp;</span></div>
		<header class="entry-header">
			<h1 class="entry-title">
				Major Goat-stealing Ring &#8211; Bog Walk Politician Nabs Suspect, Saves Him From Mob			</h1>
		</header>

		<div class="below-entry-meta">
			<span class="posted-on"><a href="https://jamaicabeacon.com/exclusive-news-stories/major-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob" title="11:32 am" rel="bookmark"><i class="fa fa-calendar-o"></i> <time class="entry-date published" datetime="2022-03-14T11:32:03-05:00">March 14, 2022</time><time class="updated" datetime="2022-03-14T12:11:33-05:00">March 14, 2022</time></a></span>
			<span class="byline">
				<span class="author vcard">
					<i class="fa fa-user"></i>
					<a class="url fn n"
					   href="https://jamaicabeacon.com/author/jamaica-beacon"
					   title="Jamaica Beacon"
					>
						Jamaica Beacon					</a>
				</span>
			</span>

							<span class="comments">
						<a href="https://jamaicabeacon.com/exclusive-news-stories/major-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob#respond"><span class="dsq-postid" data-dsqidentifier="34430 https://jamaicabeacon.com/?p=34430"><i class="fa fa-comment"></i> 0 Comments</span></a>					</span>
				</div>
		<div class="entry-content clearfix">
			
<figure class="wp-block-image size-large"><img src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Peter-Abrahams-goat.jpg" alt="" class="lazy lazy-hidden wp-image-34431" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2022/03/Peter-Abrahams-goat.jpg 800w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Peter-Abrahams-goat-300x201.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Peter-Abrahams-goat-768x515.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /><noscript><img src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Peter-Abrahams-goat.jpg" alt="" class="wp-image-34431" srcset="https://jamaicabeacon.com/wp-content/uploads/2022/03/Peter-Abrahams-goat.jpg 800w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Peter-Abrahams-goat-300x201.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Peter-Abrahams-goat-768x515.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></noscript><figcaption>Councillor for Bog Walk Division Peter Abrahams is pictured here as well as his goat that he said was returned this month when the thieves found out it belongs to him</figcaption></figure>



<p><em>Written By: Sandy Burke, Jamaica Beacon writer &#8211; St Catherine</em></p>



<p>Councillor for the Bog Walk Division in St Catherine, Peter Abrahams, said he has made a major dent in what he described as a massive goat-stealing ring affecting several communities such as Bog Walk, Guy&#8217;s Hill, Lluidas Vale and Linstead.</p>



<p>The former police officer and licensed firearm holder said he caught one of the &#8220;top men&#8221; red-handed yesterday morning, and ended up having to save him from being killed by an angry mob that descended on the scene.</p><div class="c9D7ATQR" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><!-- wp:image {"id": 10091} --><figure class="https://jamaicabeacon.com/wp-content/uploads/2019/10/IMG-20191001-WA0006.jpg"><img src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home.jpg"" class="lazy lazy-hidden wp-image-10091"/><noscript><img src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home.jpg"" class="wp-image-10091"/></noscript></figure><!-- /wp:image --></div>



<p>Abrahams said the suspect is a taxi operator from Lluidas Vale Division.</p>



<p>He was handed over to the Linstead Police.</p>



<p>The councillor said he has been doing investigation into the goat-stealing ring, and he too ended up becoming a victim of it earlier this month. </p><div class="AGyTLCET" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><!-- wp:image {"id": 10091} --><figure class="https://jamaicabeacon.com/wp-content/uploads/2019/10/IMG-20191001-WA0006.jpg"><img src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3.jpg"" class="lazy lazy-hidden wp-image-10091"/><noscript><img src="https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3.jpg"" class="wp-image-10091"/></noscript></figure><!-- /wp:image --></div>



<p>He explained that a goat he had given someone to raise was stolen at August Town in Bog Walk and, when the thieves found out that it belongs to him, they left it at Ewarton district for him to recover Ash Wednesday.</p>



<p>In relation to the incident yesterday morning, Abrahams stated that he was driving on the highway heading towards Rosemount round-about in Linstead.</p>



<p>He said he was about three cars behind the one that turned out to be transporting the two suspected goat thieves. </p>



<p>&#8220;I see one of the cars move to the left out of the line of traffic, and I saw one of the persons alighted out of the vehicle and grabbed one of the goats and pushed him in the vehicle. He grabbed another goat and also pushed it in the car,&#8221; Abrahams claimed. &#8220;I swing across to the left and blocked the vehicle from moving.&#8221; </p><div class="YMSqXals" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><!-- wp:image {"id": 10091} --><figure class="https://jamaicabeacon.com/wp-content/uploads/2019/10/IMG-20191001-WA0006.jpg"><img src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/01/Vashauns-Funeral-Service-trial.jpg"" class="lazy lazy-hidden wp-image-10091"/><noscript><img src="https://jamaicabeacon.com/wp-content/uploads/2022/01/Vashauns-Funeral-Service-trial.jpg"" class="wp-image-10091"/></noscript></figure><!-- /wp:image --></div>



<p>Abrahams added that he alighted from his vehicle with his licensed firearm and accosted the suspects. </p>



<p>One of them escaped because a goat &#8220;pushed him out of the car&#8221;, Abrahams added.</p>



<p>The driver was captured.</p><div class="xp0J6QC4" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><!-- wp:image {"id": 10091} --><figure class="https://jamaicabeacon.com/wp-content/uploads/2019/10/IMG-20191001-WA0006.jpg"><img src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Absolute-Care-1.jpg"" class="lazy lazy-hidden wp-image-10091"/><noscript><img src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Absolute-Care-1.jpg"" class="wp-image-10091"/></noscript></figure><!-- /wp:image --></div>



<p>&#8220;He could not move,&#8221; Abrahams said.</p>



<p>While the driver was pinned down along the highway, a number of people coverged on the scene, stating that they too have been victims.</p>



<p>&#8220;People did want kill the driver pon the spot; mi haffi save him. One guy jook after him with a knife and mi haffi bounce the guy. Everybody want kill him,&#8221; Abrahams said. &#8220;It is a goat-stealing ring that we wanted to break. We the citizens have to get involved now based on what is going on in this country and we have to stand up. I was doing an undercover investigation on this team and luckily I caught them red-handed yesterday myself.&#8221;</p>



<p>Abrahams further said: &#8220;I hand the driver over to the Linstead Police and his vehicle was towed away to the police station also… Him [allegedly] travel with two licence plates &#8211; a red licence plate and a private plate.&#8221;</p><div class='code-block code-block-4' style='margin: 8px 0; clear: both;'>
<script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive-Advert -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-5672174960861627"
     data-ad-slot="2167513911"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>




<p>The politician lamented that praedial larceny is a major issue in the area.</p>



<p>&#8220;I am appealing to whoever is coming in the Bog Walk and Linstead surrounding in my region; I am appealing to them to think twice because I am always on the go and I am securing my territory,&#8221; he added.</p>



<p>In the meantime, an amateur video captured at the scene yesterday shows the driver begging for his life. &#8220;Beg yuh a chance nuh,&#8221; he told Abrahams while under restraint on the roadway. </p>



<p>&#8220;A suffer mi a suffer,&#8221; the driver claimed, adding that he has a child to support. </p><div class="4r01t3zT" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><!-- wp:image {"id": 10091} --><figure class="https://jamaicabeacon.com/wp-content/uploads/2019/10/IMG-20191001-WA0006.jpg"><img src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2021/10/Bread-and-Butter-Express-ad.jpg"" class="lazy lazy-hidden wp-image-10091"/><noscript><img src="https://jamaicabeacon.com/wp-content/uploads/2021/10/Bread-and-Butter-Express-ad.jpg"" class="wp-image-10091"/></noscript></figure><!-- /wp:image --></div>



<p>&#8220;Mi can&#8217;t goh back a dem place deh (jail),&#8221; he said before being turned over to the police.</p>



<p>NOTE: To watch our upcoming videos and stand a chance of winning 100,000 dollars, subscribe to our YouTube channel by&nbsp;<a href="https://www.youtube.com/channel/UCVgr2P9uomLurrQlKrY7MFg">CLICKING HERE</a>. </p>
<span class="cp-load-after-post"></span><hr>
<p>We want to highlight your success stories - stories about challenges you overcame. Contact us at 876-305-4574 or jamaicabeaconnews@gmail.com.</p><div class="addtoany_share_save_container addtoany_content addtoany_content_bottom"><div class="a2a_kit a2a_kit_size_34 addtoany_list" data-a2a-url="https://jamaicabeacon.com/exclusive-news-stories/major-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob" data-a2a-title="Major Goat-stealing Ring – Bog Walk Politician Nabs Suspect, Saves Him From Mob"><a class="a2a_button_facebook" href="https://www.addtoany.com/add_to/facebook?linkurl=https%3A%2F%2Fjamaicabeacon.com%2Fexclusive-news-stories%2Fmajor-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob&amp;linkname=Major%20Goat-stealing%20Ring%20%E2%80%93%20Bog%20Walk%20Politician%20Nabs%20Suspect%2C%20Saves%20Him%20From%20Mob" title="Facebook" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://www.addtoany.com/add_to/twitter?linkurl=https%3A%2F%2Fjamaicabeacon.com%2Fexclusive-news-stories%2Fmajor-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob&amp;linkname=Major%20Goat-stealing%20Ring%20%E2%80%93%20Bog%20Walk%20Politician%20Nabs%20Suspect%2C%20Saves%20Him%20From%20Mob" title="Twitter" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_whatsapp" href="https://www.addtoany.com/add_to/whatsapp?linkurl=https%3A%2F%2Fjamaicabeacon.com%2Fexclusive-news-stories%2Fmajor-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob&amp;linkname=Major%20Goat-stealing%20Ring%20%E2%80%93%20Bog%20Walk%20Politician%20Nabs%20Suspect%2C%20Saves%20Him%20From%20Mob" title="WhatsApp" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_email" href="https://www.addtoany.com/add_to/email?linkurl=https%3A%2F%2Fjamaicabeacon.com%2Fexclusive-news-stories%2Fmajor-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob&amp;linkname=Major%20Goat-stealing%20Ring%20%E2%80%93%20Bog%20Walk%20Politician%20Nabs%20Suspect%2C%20Saves%20Him%20From%20Mob" title="Email" rel="nofollow noopener" target="_blank"></a><a class="a2a_button_facebook_messenger" href="https://www.addtoany.com/add_to/facebook_messenger?linkurl=https%3A%2F%2Fjamaicabeacon.com%2Fexclusive-news-stories%2Fmajor-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob&amp;linkname=Major%20Goat-stealing%20Ring%20%E2%80%93%20Bog%20Walk%20Politician%20Nabs%20Suspect%2C%20Saves%20Him%20From%20Mob" title="Facebook Messenger" rel="nofollow noopener" target="_blank"></a><a class="a2a_dd addtoany_share_save addtoany_share" href="https://www.addtoany.com/share"></a></div></div><!-- AI CONTENT END 2 -->
		</div>

	</div>

	</article>

		</div><!-- #content -->

		
		<ul class="default-wp-page clearfix">
			<li class="previous"><a href="https://jamaicabeacon.com/news/cop-who-reportedly-commits-suicide-suffered-broken-leg-tested-positive-for-covid-19" rel="prev"><span class="meta-nav">&larr;</span> Cop Who Reportedly Commits Suicide Suffered Broken Leg, Tested Positive For COVID-19</a></li>
			<li class="next"></li>
		</ul>

		
<div id="disqus_thread"></div>

	</div><!-- #primary -->


<div id="secondary">
	
	<aside id="search-2" class="widget widget_search clearfix">
<form action="https://jamaicabeacon.com/" class="search-form searchform clearfix" method="get" role="search">

	<div class="search-wrap">
		<input type="search"
		       class="s field"
		       name="s"
		       value=""
		       placeholder="Search"
		/>

		<button class="search-icon" type="submit"></button>
	</div>

</form><!-- .searchform -->
</aside><aside id="media_image-58" class="widget widget_media_image clearfix"><a href="https://jamaicabeacon.com/wp-content/uploads/2022/03/Renew-March-ad.jpg"><img width="300" height="300" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Renew-March-ad-300x300.jpg" class="lazy lazy-hidden image wp-image-34412  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2022/03/Renew-March-ad-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Renew-March-ad-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Renew-March-ad-768x768.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Renew-March-ad.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /><noscript><img width="300" height="300" src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Renew-March-ad-300x300.jpg" class="image wp-image-34412  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://jamaicabeacon.com/wp-content/uploads/2022/03/Renew-March-ad-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Renew-March-ad-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Renew-March-ad-768x768.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Renew-March-ad.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></aside><aside id="media_image-43" class="widget widget_media_image clearfix"><h3 class="widget-title"><span>Linstead Dermatologist</span></h3><a href="https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD.jpg"><img width="300" height="300" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD-300x300.jpg" class="lazy lazy-hidden image wp-image-33239  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" title="Linstead Dermatologist" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD-768x768.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /><noscript><img width="300" height="300" src="https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD-300x300.jpg" class="image wp-image-33239  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" title="Linstead Dermatologist" srcset="https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD-768x768.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></aside><aside id="media_image-41" class="widget widget_media_image clearfix"><h3 class="widget-title"><span>Linstead Make-Up</span></h3><a href="https://jamaicabeacon.com/wp-content/uploads/2020/07/Ad-make-up-artist.jpg"><img width="300" height="250" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2020/07/Ad-make-up-artist-300x250.jpg" class="lazy lazy-hidden image wp-image-24373  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" title="Linstead Make-Up" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2020/07/Ad-make-up-artist-300x250.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2020/07/Ad-make-up-artist-768x640.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2020/07/Ad-make-up-artist.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /><noscript><img width="300" height="250" src="https://jamaicabeacon.com/wp-content/uploads/2020/07/Ad-make-up-artist-300x250.jpg" class="image wp-image-24373  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" title="Linstead Make-Up" srcset="https://jamaicabeacon.com/wp-content/uploads/2020/07/Ad-make-up-artist-300x250.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2020/07/Ad-make-up-artist-768x640.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2020/07/Ad-make-up-artist.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></aside><aside id="media_image-40" class="widget widget_media_image clearfix"><h3 class="widget-title"><span>BUY GROCERIES</span></h3><a href="https://jamaicabeacon.com/wp-content/uploads/2021/10/Bread-and-Butter-Express-ad.jpg"><img width="300" height="300" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar-300x300.jpg" class="lazy lazy-hidden image wp-image-33238  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" title="BUY GROCERIES" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar-768x768.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /><noscript><img width="300" height="300" src="https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar-300x300.jpg" class="image wp-image-33238  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" title="BUY GROCERIES" srcset="https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar-768x768.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></aside><aside id="media_image-51" class="widget widget_media_image clearfix"><h3 class="widget-title"><span>SPANISH TOWN &#8211; KIDS STORE</span></h3><a href="https://www.instagram.com/leahbella_baby1/"><img width="300" height="300" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/02/Kids-Store-300x300.jpg" class="lazy lazy-hidden image wp-image-33998  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" title="SPANISH TOWN - KIDS STORE" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2022/02/Kids-Store-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/02/Kids-Store-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2022/02/Kids-Store-768x768.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2022/02/Kids-Store.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /><noscript><img width="300" height="300" src="https://jamaicabeacon.com/wp-content/uploads/2022/02/Kids-Store-300x300.jpg" class="image wp-image-33998  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" title="SPANISH TOWN - KIDS STORE" srcset="https://jamaicabeacon.com/wp-content/uploads/2022/02/Kids-Store-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/02/Kids-Store-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2022/02/Kids-Store-768x768.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2022/02/Kids-Store.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></aside><aside id="media_image-45" class="widget widget_media_image clearfix"><h3 class="widget-title"><span>Kellits Insurance</span></h3><a href="https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad.jpg"><img width="300" height="300" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad-300x300.jpg" class="lazy lazy-hidden image wp-image-32971  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" title="Kellits Insurance" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad-768x768.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /><noscript><img width="300" height="300" src="https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad-300x300.jpg" class="image wp-image-32971  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" title="Kellits Insurance" srcset="https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad-768x768.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></aside><aside id="paypal_donations-8" class="widget widget_paypal_donations clearfix"><h3 class="widget-title"><span>DONATE</span></h3><p>Make a donation today - however small, to help us continue providing life-changing stories, and giving a voice to those who otherwise may never be heard.</p>
<!-- Begin PayPal Donations by https://www.tipsandtricks-hq.com/paypal-donations-widgets-plugin -->

<form action="https://www.paypal.com/cgi-bin/webscr" method="post">
    <div class="paypal-donations">
        <input type="hidden" name="cmd" value="_donations" />
        <input type="hidden" name="bn" value="TipsandTricks_SP" />
        <input type="hidden" name="business" value="jamaicabeaconnews@gmail.com" />
        <input type="hidden" name="rm" value="0" />
        <input type="hidden" name="currency_code" value="USD" />
        <input type="image" style="cursor: pointer;" src="https://www.paypal.com/en_US/i/btn/btn_donateCC_LG.gif" name="submit" alt="PayPal - The safer, easier way to pay online." />
        <img class="lazy lazy-hidden" alt="" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1" /><noscript><img alt="" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1" /></noscript>
    </div>
</form>
<!-- End PayPal Donations -->
</aside><aside id="media_image-33" class="widget widget_media_image clearfix"><h3 class="widget-title"><span>BREAK BARRIERS &#8211; Senior Citizens</span></h3><a href="https://jamaicabeacon.com/wp-content/uploads/2021/02/Break-Barriers.jpg"><img width="211" height="300" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2021/02/Break-Barriers-211x300.jpg" class="lazy lazy-hidden image wp-image-28853  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" title="BREAK BARRIERS - Senior Citizens" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2021/02/Break-Barriers-211x300.jpg 211w, https://jamaicabeacon.com/wp-content/uploads/2021/02/Break-Barriers-721x1024.jpg 721w, https://jamaicabeacon.com/wp-content/uploads/2021/02/Break-Barriers-768x1091.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2021/02/Break-Barriers.jpg 800w" sizes="(max-width: 211px) 100vw, 211px" /><noscript><img width="211" height="300" src="https://jamaicabeacon.com/wp-content/uploads/2021/02/Break-Barriers-211x300.jpg" class="image wp-image-28853  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" title="BREAK BARRIERS - Senior Citizens" srcset="https://jamaicabeacon.com/wp-content/uploads/2021/02/Break-Barriers-211x300.jpg 211w, https://jamaicabeacon.com/wp-content/uploads/2021/02/Break-Barriers-721x1024.jpg 721w, https://jamaicabeacon.com/wp-content/uploads/2021/02/Break-Barriers-768x1091.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2021/02/Break-Barriers.jpg 800w" sizes="(max-width: 211px) 100vw, 211px" /></noscript></a></aside><aside id="media_image-44" class="widget widget_media_image clearfix"><h3 class="widget-title"><span>Linstead Pharmacy</span></h3><a href="https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3.jpg"><img width="300" height="300" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3-300x300.jpg" class="lazy lazy-hidden image wp-image-27803  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" title="Linstead Pharmacy" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3-768x768.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /><noscript><img width="300" height="300" src="https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3-300x300.jpg" class="image wp-image-27803  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" title="Linstead Pharmacy" srcset="https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3-768x768.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></a></aside><aside id="text-2" class="widget widget_text clearfix"><h3 class="widget-title"><span>CONTACT US:</span></h3>			<div class="textwidget"><p>WhatsApp OR call: <strong>876-305-4574</strong></p>
<p>Email: <strong>jamaicabeaconnews@gmail.com</strong></p>
</div>
		</aside><aside id="media_image-19" class="widget widget_media_image clearfix"><h3 class="widget-title"><span>LINSTEAD &#8211; GAS STATION</span></h3><a href="https://jamaicabeacon.com/wp-content/uploads/2021/06/Kings-Landing.jpg"><img width="230" height="300" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2021/06/Kings-Landing-230x300.jpg" class="lazy lazy-hidden image wp-image-30315  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" title="LINSTEAD - GAS STATION" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2021/06/Kings-Landing-230x300.jpg 230w, https://jamaicabeacon.com/wp-content/uploads/2021/06/Kings-Landing-785x1024.jpg 785w, https://jamaicabeacon.com/wp-content/uploads/2021/06/Kings-Landing-768x1002.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2021/06/Kings-Landing.jpg 800w" sizes="(max-width: 230px) 100vw, 230px" /><noscript><img width="230" height="300" src="https://jamaicabeacon.com/wp-content/uploads/2021/06/Kings-Landing-230x300.jpg" class="image wp-image-30315  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" title="LINSTEAD - GAS STATION" srcset="https://jamaicabeacon.com/wp-content/uploads/2021/06/Kings-Landing-230x300.jpg 230w, https://jamaicabeacon.com/wp-content/uploads/2021/06/Kings-Landing-785x1024.jpg 785w, https://jamaicabeacon.com/wp-content/uploads/2021/06/Kings-Landing-768x1002.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2021/06/Kings-Landing.jpg 800w" sizes="(max-width: 230px) 100vw, 230px" /></noscript></a></aside><aside id="media_image-32" class="widget widget_media_image clearfix"><h3 class="widget-title"><span>SHOPPING &#8211; (Click The Ad)</span></h3><a href="https://breadandbutterexpress.com/"><img width="800" height="800" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar.jpg" class="lazy lazy-hidden image wp-image-33238  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar.jpg 800w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar-768x768.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /><noscript><img width="800" height="800" src="https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar.jpg" class="image wp-image-33238  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar.jpg 800w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Bread-and-Butter-Express-ad-sidebar-768x768.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></noscript></a></aside><aside id="media_image-35" class="widget widget_media_image clearfix"><h3 class="widget-title"><span>LINSTEAD &#8211; RENEW</span></h3><a href="https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD.jpg"><img width="800" height="800" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD.jpg" class="lazy lazy-hidden image wp-image-33239  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD.jpg 800w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD-768x768.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /><noscript><img width="800" height="800" src="https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD.jpg" class="image wp-image-33239  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD.jpg 800w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Renew-spa-SIDEBAR-AD-768x768.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></noscript></a></aside><aside id="a2a_follow_widget-2" class="widget widget_a2a_follow_widget clearfix"><h3 class="widget-title"><span>FOLLOW THE BEACON:</span></h3><div class="a2a_kit a2a_kit_size_64 a2a_follow addtoany_list"><a class="a2a_button_facebook" href="https://www.facebook.com/JamaicaBeacon/?modal=admin_todo_tour" title="Facebook" rel="noopener" target="_blank"></a><a class="a2a_button_twitter" href="https://twitter.com/BeaconJamaica" title="Twitter" rel="noopener" target="_blank"></a><a class="a2a_button_instagram" href="https://www.instagram.com/jamaicabeacon/" title="Instagram" rel="noopener" target="_blank"></a><a class="a2a_button_youtube_channel" href="https://www.youtube.com/channel/UCVgr2P9uomLurrQlKrY7MFg?view_as=subscriber" title="YouTube Channel" rel="noopener" target="_blank"></a></div></aside><aside id="top-posts-2" class="widget widget_top-posts clearfix"><h3 class="widget-title"><span>MOST POPULAR STORIES</span></h3><ul class='widgets-list-layout no-grav'>
					<li>
						<a href="https://jamaicabeacon.com/news/linstead-family-in-grief-mothers-only-child-dies-in-usa-crash-while-taking-her-to-airport" title="Linstead Family In Grief | Mother&#039;s Only Child Dies In USA Crash While Taking Her To Airport" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://i0.wp.com/jamaicabeacon.com/wp-content/uploads/2022/03/Michael-Smith-1.jpg?resize=40%2C40&#038;ssl=1" alt="Linstead Family In Grief | Mother&#039;s Only Child Dies In USA Crash While Taking Her To Airport" data-pin-nopin="true" class="lazy lazy-hidden widgets-list-layout-blavatar"/><noscript><img width="40" height="40" src="https://i0.wp.com/jamaicabeacon.com/wp-content/uploads/2022/03/Michael-Smith-1.jpg?resize=40%2C40&#038;ssl=1" alt="Linstead Family In Grief | Mother&#039;s Only Child Dies In USA Crash While Taking Her To Airport" data-pin-nopin="true" class="widgets-list-layout-blavatar"/></noscript>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://jamaicabeacon.com/news/linstead-family-in-grief-mothers-only-child-dies-in-usa-crash-while-taking-her-to-airport" title="Linstead Family In Grief | Mother&#039;s Only Child Dies In USA Crash While Taking Her To Airport" class="bump-view" data-bump-view="tp">Linstead Family In Grief | Mother&#039;s Only Child Dies In USA Crash While Taking Her To Airport</a>
							</div>
													</li>
										<li>
						<a href="https://jamaicabeacon.com/news/cop-who-reportedly-commits-suicide-suffered-broken-leg-tested-positive-for-covid-19" title="Cop Who Reportedly Commits Suicide Suffered Broken Leg, Tested Positive For COVID-19" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://i2.wp.com/jamaicabeacon.com/wp-content/uploads/2022/03/Osbourne-Ximines.jpg?resize=40%2C40&#038;ssl=1" alt="Cop Who Reportedly Commits Suicide Suffered Broken Leg, Tested Positive For COVID-19" data-pin-nopin="true" class="lazy lazy-hidden widgets-list-layout-blavatar"/><noscript><img width="40" height="40" src="https://i2.wp.com/jamaicabeacon.com/wp-content/uploads/2022/03/Osbourne-Ximines.jpg?resize=40%2C40&#038;ssl=1" alt="Cop Who Reportedly Commits Suicide Suffered Broken Leg, Tested Positive For COVID-19" data-pin-nopin="true" class="widgets-list-layout-blavatar"/></noscript>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://jamaicabeacon.com/news/cop-who-reportedly-commits-suicide-suffered-broken-leg-tested-positive-for-covid-19" title="Cop Who Reportedly Commits Suicide Suffered Broken Leg, Tested Positive For COVID-19" class="bump-view" data-bump-view="tp">Cop Who Reportedly Commits Suicide Suffered Broken Leg, Tested Positive For COVID-19</a>
							</div>
													</li>
										<li>
						<a href="https://jamaicabeacon.com/beacon-of-the-day/her-children-on-her-mind-st-thomas-farm-worker-eager-to-face-the-cold-again" title="Her Children On Her Mind - St Thomas Farm Worker Ready To Face The Cold Again" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://i1.wp.com/jamaicabeacon.com/wp-content/uploads/2022/03/Herchelle-Crosdale-1.jpg?resize=40%2C40&#038;ssl=1" alt="Her Children On Her Mind - St Thomas Farm Worker Ready To Face The Cold Again" data-pin-nopin="true" class="lazy lazy-hidden widgets-list-layout-blavatar"/><noscript><img width="40" height="40" src="https://i1.wp.com/jamaicabeacon.com/wp-content/uploads/2022/03/Herchelle-Crosdale-1.jpg?resize=40%2C40&#038;ssl=1" alt="Her Children On Her Mind - St Thomas Farm Worker Ready To Face The Cold Again" data-pin-nopin="true" class="widgets-list-layout-blavatar"/></noscript>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://jamaicabeacon.com/beacon-of-the-day/her-children-on-her-mind-st-thomas-farm-worker-eager-to-face-the-cold-again" title="Her Children On Her Mind - St Thomas Farm Worker Ready To Face The Cold Again" class="bump-view" data-bump-view="tp">Her Children On Her Mind - St Thomas Farm Worker Ready To Face The Cold Again</a>
							</div>
													</li>
										<li>
						<a href="https://jamaicabeacon.com/news/linstead-man-killed-in-banbury-is-richard-webb-another-resident-hospitalized" title="Linstead | Man Killed In Banbury Is Richard Webb; Another Resident Hospitalized" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://i1.wp.com/jamaicabeacon.com/wp-content/uploads/2022/03/Linstead-Police.jpg?resize=40%2C40&#038;ssl=1" alt="Linstead | Man Killed In Banbury Is Richard Webb; Another Resident Hospitalized" data-pin-nopin="true" class="lazy lazy-hidden widgets-list-layout-blavatar"/><noscript><img width="40" height="40" src="https://i1.wp.com/jamaicabeacon.com/wp-content/uploads/2022/03/Linstead-Police.jpg?resize=40%2C40&#038;ssl=1" alt="Linstead | Man Killed In Banbury Is Richard Webb; Another Resident Hospitalized" data-pin-nopin="true" class="widgets-list-layout-blavatar"/></noscript>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://jamaicabeacon.com/news/linstead-man-killed-in-banbury-is-richard-webb-another-resident-hospitalized" title="Linstead | Man Killed In Banbury Is Richard Webb; Another Resident Hospitalized" class="bump-view" data-bump-view="tp">Linstead | Man Killed In Banbury Is Richard Webb; Another Resident Hospitalized</a>
							</div>
													</li>
										<li>
						<a href="https://jamaicabeacon.com/exclusive-news-stories/major-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob" title="Major Goat-stealing Ring - Bog Walk Politician Nabs Suspect, Saves Him From Mob" class="bump-view" data-bump-view="tp" aria-current="page">
								<img width="40" height="40" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://i2.wp.com/jamaicabeacon.com/wp-content/uploads/2022/03/Peter-Abrahams-goat.jpg?resize=40%2C40&#038;ssl=1" alt="Major Goat-stealing Ring - Bog Walk Politician Nabs Suspect, Saves Him From Mob" data-pin-nopin="true" class="lazy lazy-hidden widgets-list-layout-blavatar"/><noscript><img width="40" height="40" src="https://i2.wp.com/jamaicabeacon.com/wp-content/uploads/2022/03/Peter-Abrahams-goat.jpg?resize=40%2C40&#038;ssl=1" alt="Major Goat-stealing Ring - Bog Walk Politician Nabs Suspect, Saves Him From Mob" data-pin-nopin="true" class="widgets-list-layout-blavatar"/></noscript>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://jamaicabeacon.com/exclusive-news-stories/major-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob" title="Major Goat-stealing Ring - Bog Walk Politician Nabs Suspect, Saves Him From Mob" class="bump-view" data-bump-view="tp" aria-current="page">Major Goat-stealing Ring - Bog Walk Politician Nabs Suspect, Saves Him From Mob</a>
							</div>
													</li>
										<li>
						<a href="https://jamaicabeacon.com/news/linstead-wanderer-found-far-from-home-prompting-cops-to-make-another-appeal" title="Linstead Wanderer Found Far From Home, Prompting Cops To Make Another Appeal" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://i1.wp.com/jamaicabeacon.com/wp-content/uploads/2022/03/Shaquille-Thomas.png?resize=40%2C40&#038;ssl=1" alt="Linstead Wanderer Found Far From Home, Prompting Cops To Make Another Appeal" data-pin-nopin="true" class="lazy lazy-hidden widgets-list-layout-blavatar"/><noscript><img width="40" height="40" src="https://i1.wp.com/jamaicabeacon.com/wp-content/uploads/2022/03/Shaquille-Thomas.png?resize=40%2C40&#038;ssl=1" alt="Linstead Wanderer Found Far From Home, Prompting Cops To Make Another Appeal" data-pin-nopin="true" class="widgets-list-layout-blavatar"/></noscript>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://jamaicabeacon.com/news/linstead-wanderer-found-far-from-home-prompting-cops-to-make-another-appeal" title="Linstead Wanderer Found Far From Home, Prompting Cops To Make Another Appeal" class="bump-view" data-bump-view="tp">Linstead Wanderer Found Far From Home, Prompting Cops To Make Another Appeal</a>
							</div>
													</li>
										<li>
						<a href="https://jamaicabeacon.com/linstead-news/burial-now-in-sight-for-linstead-youth-murdered-3-years-ago" title="Burial Now In Sight For Linstead Youth Murdered 3 Years Ago" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://i1.wp.com/jamaicabeacon.com/wp-content/uploads/2022/03/Terrence-Gayle.jpg?resize=40%2C40&#038;ssl=1" alt="Burial Now In Sight For Linstead Youth Murdered 3 Years Ago" data-pin-nopin="true" class="lazy lazy-hidden widgets-list-layout-blavatar"/><noscript><img width="40" height="40" src="https://i1.wp.com/jamaicabeacon.com/wp-content/uploads/2022/03/Terrence-Gayle.jpg?resize=40%2C40&#038;ssl=1" alt="Burial Now In Sight For Linstead Youth Murdered 3 Years Ago" data-pin-nopin="true" class="widgets-list-layout-blavatar"/></noscript>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://jamaicabeacon.com/linstead-news/burial-now-in-sight-for-linstead-youth-murdered-3-years-ago" title="Burial Now In Sight For Linstead Youth Murdered 3 Years Ago" class="bump-view" data-bump-view="tp">Burial Now In Sight For Linstead Youth Murdered 3 Years Ago</a>
							</div>
													</li>
										<li>
						<a href="https://jamaicabeacon.com/news/mother-hosts-candlelight-vigil-says-daughter-found-murdered-in-soldiers-car" title="Mother Hosts Candlelight Vigil, Says Daughter Found Murdered In Soldier&#039;s Car" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://i2.wp.com/jamaicabeacon.com/wp-content/uploads/2022/03/Oshine-Lawrence-1.jpg?resize=40%2C40&#038;ssl=1" alt="Mother Hosts Candlelight Vigil, Says Daughter Found Murdered In Soldier&#039;s Car" data-pin-nopin="true" class="lazy lazy-hidden widgets-list-layout-blavatar"/><noscript><img width="40" height="40" src="https://i2.wp.com/jamaicabeacon.com/wp-content/uploads/2022/03/Oshine-Lawrence-1.jpg?resize=40%2C40&#038;ssl=1" alt="Mother Hosts Candlelight Vigil, Says Daughter Found Murdered In Soldier&#039;s Car" data-pin-nopin="true" class="widgets-list-layout-blavatar"/></noscript>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://jamaicabeacon.com/news/mother-hosts-candlelight-vigil-says-daughter-found-murdered-in-soldiers-car" title="Mother Hosts Candlelight Vigil, Says Daughter Found Murdered In Soldier&#039;s Car" class="bump-view" data-bump-view="tp">Mother Hosts Candlelight Vigil, Says Daughter Found Murdered In Soldier&#039;s Car</a>
							</div>
													</li>
										<li>
						<a href="https://jamaicabeacon.com/news/exclusive-young-father-shot-dead-on-second-attempt-at-bar" title="Exclusive | Young father shot dead on second attempt at bar" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://i2.wp.com/jamaicabeacon.com/wp-content/uploads/2021/04/Oniel-1.jpg?resize=40%2C40&#038;ssl=1" alt="Exclusive | Young father shot dead on second attempt at bar" data-pin-nopin="true" class="lazy lazy-hidden widgets-list-layout-blavatar"/><noscript><img width="40" height="40" src="https://i2.wp.com/jamaicabeacon.com/wp-content/uploads/2021/04/Oniel-1.jpg?resize=40%2C40&#038;ssl=1" alt="Exclusive | Young father shot dead on second attempt at bar" data-pin-nopin="true" class="widgets-list-layout-blavatar"/></noscript>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://jamaicabeacon.com/news/exclusive-young-father-shot-dead-on-second-attempt-at-bar" title="Exclusive | Young father shot dead on second attempt at bar" class="bump-view" data-bump-view="tp">Exclusive | Young father shot dead on second attempt at bar</a>
							</div>
													</li>
										<li>
						<a href="https://jamaicabeacon.com/linstead-news/linstead-cops-identify-gunshot-victim-his-mother-was-slain-years-ago" title="Linstead Cops Identify Gunshot Victim; His Mother Was Slain Years Ago" class="bump-view" data-bump-view="tp">
								<img width="40" height="40" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://i2.wp.com/jamaicabeacon.com/wp-content/uploads/2022/02/Linstead-Police-3.jpg?resize=40%2C40&#038;ssl=1" alt="Linstead Cops Identify Gunshot Victim; His Mother Was Slain Years Ago" data-pin-nopin="true" class="lazy lazy-hidden widgets-list-layout-blavatar"/><noscript><img width="40" height="40" src="https://i2.wp.com/jamaicabeacon.com/wp-content/uploads/2022/02/Linstead-Police-3.jpg?resize=40%2C40&#038;ssl=1" alt="Linstead Cops Identify Gunshot Victim; His Mother Was Slain Years Ago" data-pin-nopin="true" class="widgets-list-layout-blavatar"/></noscript>
							</a>
							<div class="widgets-list-layout-links">
								<a href="https://jamaicabeacon.com/linstead-news/linstead-cops-identify-gunshot-victim-his-mother-was-slain-years-ago" title="Linstead Cops Identify Gunshot Victim; His Mother Was Slain Years Ago" class="bump-view" data-bump-view="tp">Linstead Cops Identify Gunshot Victim; His Mother Was Slain Years Ago</a>
							</div>
													</li>
					</ul>
</aside><aside id="media_image-29" class="widget widget_media_image clearfix"><h3 class="widget-title"><span>KELLITS &#8211; CLARENDON</span></h3><a href="https://jamaicabeacon.com/wp-content/uploads/2021/09/Fast-Print.jpg"><img width="800" height="800" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2021/09/Fast-Print.jpg" class="lazy lazy-hidden image wp-image-31768  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" title="KELLITS - CLARENDON" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2021/09/Fast-Print.jpg 800w, https://jamaicabeacon.com/wp-content/uploads/2021/09/Fast-Print-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2021/09/Fast-Print-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2021/09/Fast-Print-768x768.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /><noscript><img width="800" height="800" src="https://jamaicabeacon.com/wp-content/uploads/2021/09/Fast-Print.jpg" class="image wp-image-31768  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" title="KELLITS - CLARENDON" srcset="https://jamaicabeacon.com/wp-content/uploads/2021/09/Fast-Print.jpg 800w, https://jamaicabeacon.com/wp-content/uploads/2021/09/Fast-Print-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2021/09/Fast-Print-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2021/09/Fast-Print-768x768.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></noscript></a></aside><aside id="media_image-20" class="widget widget_media_image clearfix"><h3 class="widget-title"><span>LINSTEAD &#8211; DIXON&#8217;S PHARMACY</span></h3><a href="https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3.jpg"><img width="800" height="800" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3.jpg" class="lazy lazy-hidden image wp-image-27803  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3.jpg 800w, https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3-768x768.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /><noscript><img width="800" height="800" src="https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3.jpg" class="image wp-image-27803  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3.jpg 800w, https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2020/12/Dixons-Drug-Store-flyer-3-768x768.jpg 768w" sizes="(max-width: 800px) 100vw, 800px" /></noscript></a></aside><aside id="facebook-likebox-2" class="widget widget_facebook_likebox clearfix"><h3 class="widget-title"><span><a href="https://www.facebook.com/JamaicaBeacon/">LATEST ON FACEBOOK</a></span></h3>		<div id="fb-root"></div>
		<div class="fb-page" data-href="https://www.facebook.com/JamaicaBeacon/" data-width="340"  data-height="580" data-hide-cover="false" data-show-facepile="true" data-tabs="timeline" data-hide-cta="false" data-small-header="false">
		<div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/JamaicaBeacon/"><a href="https://www.facebook.com/JamaicaBeacon/">LATEST ON FACEBOOK</a></blockquote></div>
		</div>
		</aside><aside id="paypal_donations-2" class="widget widget_paypal_donations clearfix"><h3 class="widget-title"><span>DONATE</span></h3><p>Make a donation today - however small, to help us continue providing life-changing stories, and giving a voice to those who otherwise may never be heard.</p>
<!-- Begin PayPal Donations by https://www.tipsandtricks-hq.com/paypal-donations-widgets-plugin -->

<form action="https://www.paypal.com/cgi-bin/webscr" method="post">
    <div class="paypal-donations">
        <input type="hidden" name="cmd" value="_donations" />
        <input type="hidden" name="bn" value="TipsandTricks_SP" />
        <input type="hidden" name="business" value="jamaicabeaconnews@gmail.com" />
        <input type="hidden" name="rm" value="0" />
        <input type="hidden" name="currency_code" value="USD" />
        <input type="image" style="cursor: pointer;" src="https://www.paypal.com/en_US/i/btn/btn_donateCC_LG.gif" name="submit" alt="PayPal - The safer, easier way to pay online." />
        <img class="lazy lazy-hidden" alt="" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1" /><noscript><img alt="" src="https://www.paypal.com/en_US/i/scr/pixel.gif" width="1" height="1" /></noscript>
    </div>
</form>
<!-- End PayPal Donations -->
</aside><aside id="custom_html-8" class="widget_text widget widget_custom_html clearfix"><div class="textwidget custom-html-widget"><script async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Responsive-Advert -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-5672174960861627"
     data-ad-slot="2167513911"
     data-ad-format="auto"
     data-full-width-responsive="true"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div></aside><aside id="media_video-2" class="widget widget_media_video clearfix"><div style="width:100%;" class="wp-video"><!--[if lt IE 9]><script>document.createElement('video');</script><![endif]-->
<video class="wp-video-shortcode" id="video-34430-1" preload="metadata" controls="controls"><source class="lazy lazy-hidden" type="video/youtube" src="https://www.youtube.com/watch?v=1EQR6w5ylJA&#038;_=1" /><a href="https://www.youtube.com/watch?v=1EQR6w5ylJA">https://www.youtube.com/watch?v=1EQR6w5ylJA</a></video></div></aside><aside id="media_image-47" class="widget widget_media_image clearfix"><img width="300" height="126" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/01/Vashauns-Funeral-Service-trial-300x126.jpg" class="lazy lazy-hidden image wp-image-33522  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2022/01/Vashauns-Funeral-Service-trial-300x126.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Vashauns-Funeral-Service-trial-768x323.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Vashauns-Funeral-Service-trial.jpg 950w" sizes="(max-width: 300px) 100vw, 300px" /><noscript><img width="300" height="126" src="https://jamaicabeacon.com/wp-content/uploads/2022/01/Vashauns-Funeral-Service-trial-300x126.jpg" class="image wp-image-33522  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://jamaicabeacon.com/wp-content/uploads/2022/01/Vashauns-Funeral-Service-trial-300x126.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Vashauns-Funeral-Service-trial-768x323.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2022/01/Vashauns-Funeral-Service-trial.jpg 950w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></aside><aside id="media_image-48" class="widget widget_media_image clearfix"><img width="300" height="300" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad-300x300.jpg" class="lazy lazy-hidden image wp-image-32971  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad-768x768.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /><noscript><img width="300" height="300" src="https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad-300x300.jpg" class="image wp-image-32971  attachment-medium size-medium" alt="" style="max-width: 100%; height: auto;" srcset="https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad-300x300.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad-150x150.jpg 150w, https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad-768x768.jpg 768w, https://jamaicabeacon.com/wp-content/uploads/2021/12/Axia-Insurance-ad.jpg 800w" sizes="(max-width: 300px) 100vw, 300px" /></noscript></aside><aside id="categories-4" class="widget widget_categories clearfix"><h3 class="widget-title"><span>CATEGORIES</span></h3><form action="https://jamaicabeacon.com" method="get"><label class="screen-reader-text" for="cat">CATEGORIES</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="5033">ACADEMICS</option>
	<option class="level-0" value="5034">AWARDS</option>
	<option class="level-0" value="3861">BEACON OF THE DAY</option>
	<option class="level-0" value="5030">BIRTHDAYS</option>
	<option class="level-0" value="5054">BUSINESS</option>
	<option class="level-0" value="3432">COMMUNITY FOCUS</option>
	<option class="level-0" value="5031">COMMUNITY SERVICE</option>
	<option class="level-0" value="5056">ENTERTAINMENT</option>
	<option class="level-0" value="5059">EXCLUSIVE NEWS STORIES</option>
	<option class="level-0" value="5063">FUNERALS</option>
	<option class="level-0" value="5057">HEALTH</option>
	<option class="level-0" value="5058">LEADERSHIP</option>
	<option class="level-0" value="23">LINSTEAD</option>
	<option class="level-0" value="21">NEWS</option>
	<option class="level-0" value="4911">NEWS EXCLUSIVES</option>
	<option class="level-0" value="5064">OBITUARIES</option>
	<option class="level-0" value="5055">SPORTS</option>
	<option class="level-0" value="1">Uncategorized</option>
	<option class="level-0" value="5026">WEDDINGS</option>
</select>
</form>
<script type="text/javascript">
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

			</aside>
	</div>
		</div><!-- .inner-wrap -->
				</div><!-- #main -->
					<div class="advertisement_above_footer">
				<div class="inner-wrap">
					<aside id="media_image-59" class="widget widget_media_image clearfix"><a href="https://jamaicabeacon.com/wp-content/uploads/2022/03/Absolute-Care-1.jpg"><img width="900" height="398" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Absolute-Care-1.jpg" class="lazy lazy-hidden image wp-image-34236  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2022/03/Absolute-Care-1.jpg 900w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Absolute-Care-1-300x133.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Absolute-Care-1-768x340.jpg 768w" sizes="(max-width: 900px) 100vw, 900px" /><noscript><img width="900" height="398" src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Absolute-Care-1.jpg" class="image wp-image-34236  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://jamaicabeacon.com/wp-content/uploads/2022/03/Absolute-Care-1.jpg 900w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Absolute-Care-1-300x133.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Absolute-Care-1-768x340.jpg 768w" sizes="(max-width: 900px) 100vw, 900px" /></noscript></a></aside><aside id="media_image-60" class="widget widget_media_image clearfix"><a href="https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home.jpg"><img width="900" height="450" src="//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/images/lazy_placeholder.gif" data-lazy-type="image" data-src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home.jpg" class="lazy lazy-hidden image wp-image-34233  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="" data-srcset="https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home.jpg 900w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home-300x150.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home-768x384.jpg 768w" sizes="(max-width: 900px) 100vw, 900px" /><noscript><img width="900" height="450" src="https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home.jpg" class="image wp-image-34233  attachment-full size-full" alt="" style="max-width: 100%; height: auto;" srcset="https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home.jpg 900w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home-300x150.jpg 300w, https://jamaicabeacon.com/wp-content/uploads/2022/03/Sunset-Funeral-Home-768x384.jpg 768w" sizes="(max-width: 900px) 100vw, 900px" /></noscript></a></aside>				</div>
			</div>
					<footer id="colophon" class="clearfix ">
				<div class="footer-socket-wrapper clearfix">
			<div class="inner-wrap">
				<div class="footer-socket-area">
		
		<div class="footer-socket-right-section">
			
		<div class="social-links clearfix">
			<ul>
				<li><a href="https://www.facebook.com/JamaicaBeacon" ><i class="fa fa-facebook"></i></a></li><li><a href="https://twitter.com/BeaconJamaica" ><i class="fa fa-twitter"></i></a></li><li><a href="https://www.instagram.com/jamaicabeaconnews" ><i class="fa fa-instagram"></i></a></li><li><a href="https://www.youtube.com/channel/UCVgr2P9uomLurrQlKrY7MFg?view_as=subscriber" ><i class="fa fa-youtube"></i></a></li>			</ul>
		</div><!-- .social-links -->
				</div>

				<div class="footer-socket-left-section">
			<div class="copyright">Copyright &copy; 2022 <a href="https://jamaicabeacon.com/" title="Jamaica Beacon" ><span>Jamaica Beacon</span></a>. All rights reserved.<br>Theme: <a href="https://themegrill.com/themes/colormag" target="_blank" title="ColorMag" rel="nofollow"><span>ColorMag</span></a> by ThemeGrill. Powered by <a href="https://wordpress.org" target="_blank" title="WordPress" rel="nofollow"><span>WordPress</span></a>.</div>		</div>
				</div><!-- .footer-socket-area -->
					</div><!-- .inner-wrap -->
		</div><!-- .footer-socket-wrapper -->
				</footer><!-- #colophon -->
				<a href="#masthead" id="scroll-up"><i class="fa fa-chevron-up"></i></a>
				</div><!-- #page -->
		<!-- ngg_resource_manager_marker --><script>if (document.location.protocol != "https:") {document.location = document.URL.replace(/^http:/i, "https:");}</script><script type='text/javascript'>
/* <![CDATA[ */
var wpcf7 = {"apiSettings":{"root":"https:\/\/jamaicabeacon.com\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/contact-form-7/includes/js/scripts.js?ver=5.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"jamaica-beacon"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"34430 https:\/\/jamaicabeacon.com\/?p=34430","disqusShortname":"jamaica-beacon","disqusTitle":"Major Goat-stealing Ring \u2013 Bog Walk Politician Nabs Suspect, Saves Him From Mob","disqusUrl":"https:\/\/jamaicabeacon.com\/exclusive-news-stories\/major-goat-stealing-ring-bog-walk-politician-nabs-suspect-saves-him-from-mob","postId":"34430"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/penci-pennews-recipe/js/jquery.rateyo.min.js?ver=2.3'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PENCI = {"ajaxUrl":"https:\/\/jamaicabeacon.com\/wp-admin\/admin-ajax.php","nonce":"1376133d64","normalFill":"#b9b9b9","ratedFill":"#FFCA00"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/penci-pennews-recipe/js/rating_recipe.js?ver=2.3.2'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/penci-pennews-review/js/jquery.easypiechart.min.js?ver=1.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var PENCI = {"postID":"34430","ajaxUrl":"https:\/\/jamaicabeacon.com\/wp-admin\/admin-ajax.php","nonce":"1376133d64","normalFill":"#b9b9b9","ratedFill":"#FFCA00"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/penci-pennews-review/js/rating_review.js?ver=3.0'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-includes/js/comment-reply.min.js?ver=5.3.12'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/themes/colormag/js/jquery.bxslider.min.js?ver=2.0.9'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/themes/colormag/js/navigation.min.js?ver=2.0.9'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/themes/colormag/js/fitvids/jquery.fitvids.min.js?ver=2.0.9'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/themes/colormag/js/skip-link-focus-fix.min.js?ver=2.0.9'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/themes/colormag/js/colormag-custom.min.js?ver=2.0.9'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var jpfbembed = {"appid":"249643311490","locale":"en_US"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-content/plugins/jetpack/_inc/build/facebook-embed.min.js'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var a3_lazyload_params = {"apply_images":"1","apply_videos":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.extra.min.js?ver=2.4.7'></script>
<script type='text/javascript' src='//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.srcset.min.js?ver=2.4.7'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var a3_lazyload_extend_params = {"edgeY":"0","horizontal_container_classnames":""};
/* ]]> */
</script>
<script type='text/javascript' src='//jamaicabeacon.com/wp-content/plugins/a3-lazy-load/assets/js/jquery.lazyloadxt.extend.js?ver=2.4.7'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-includes/js/wp-embed.min.js?ver=5.3.12'></script>
<script type='text/javascript' src='https://cdn.onesignal.com/sdks/OneSignalSDK.js?ver=5.3.12' async='async'></script>
<script type='text/javascript'>
var mejsL10n = {"language":"en","strings":{"mejs.install-flash":"You are using a browser that does not have Flash player enabled or installed. Please turn on your Flash player plugin or download the latest version from https:\/\/get.adobe.com\/flashplayer\/","mejs.fullscreen-off":"Turn off Fullscreen","mejs.fullscreen-on":"Go Fullscreen","mejs.download-video":"Download Video","mejs.fullscreen":"Fullscreen","mejs.time-jump-forward":["Jump forward 1 second","Jump forward %1 seconds"],"mejs.loop":"Toggle Loop","mejs.play":"Play","mejs.pause":"Pause","mejs.close":"Close","mejs.time-slider":"Time Slider","mejs.time-help-text":"Use Left\/Right Arrow keys to advance one second, Up\/Down arrows to advance ten seconds.","mejs.time-skip-back":["Skip back 1 second","Skip back %1 seconds"],"mejs.captions-subtitles":"Captions\/Subtitles","mejs.captions-chapters":"Chapters","mejs.none":"None","mejs.mute-toggle":"Mute Toggle","mejs.volume-help-text":"Use Up\/Down Arrow keys to increase or decrease volume.","mejs.unmute":"Unmute","mejs.mute":"Mute","mejs.volume-slider":"Volume Slider","mejs.video-player":"Video Player","mejs.audio-player":"Audio Player","mejs.ad-skip":"Skip ad","mejs.ad-skip-info":["Skip in 1 second","Skip in %1 seconds"],"mejs.source-chooser":"Source Chooser","mejs.stop":"Stop","mejs.speed-rate":"Speed Rate","mejs.live-broadcast":"Live Broadcast","mejs.afrikaans":"Afrikaans","mejs.albanian":"Albanian","mejs.arabic":"Arabic","mejs.belarusian":"Belarusian","mejs.bulgarian":"Bulgarian","mejs.catalan":"Catalan","mejs.chinese":"Chinese","mejs.chinese-simplified":"Chinese (Simplified)","mejs.chinese-traditional":"Chinese (Traditional)","mejs.croatian":"Croatian","mejs.czech":"Czech","mejs.danish":"Danish","mejs.dutch":"Dutch","mejs.english":"English","mejs.estonian":"Estonian","mejs.filipino":"Filipino","mejs.finnish":"Finnish","mejs.french":"French","mejs.galician":"Galician","mejs.german":"German","mejs.greek":"Greek","mejs.haitian-creole":"Haitian Creole","mejs.hebrew":"Hebrew","mejs.hindi":"Hindi","mejs.hungarian":"Hungarian","mejs.icelandic":"Icelandic","mejs.indonesian":"Indonesian","mejs.irish":"Irish","mejs.italian":"Italian","mejs.japanese":"Japanese","mejs.korean":"Korean","mejs.latvian":"Latvian","mejs.lithuanian":"Lithuanian","mejs.macedonian":"Macedonian","mejs.malay":"Malay","mejs.maltese":"Maltese","mejs.norwegian":"Norwegian","mejs.persian":"Persian","mejs.polish":"Polish","mejs.portuguese":"Portuguese","mejs.romanian":"Romanian","mejs.russian":"Russian","mejs.serbian":"Serbian","mejs.slovak":"Slovak","mejs.slovenian":"Slovenian","mejs.spanish":"Spanish","mejs.swahili":"Swahili","mejs.swedish":"Swedish","mejs.tagalog":"Tagalog","mejs.thai":"Thai","mejs.turkish":"Turkish","mejs.ukrainian":"Ukrainian","mejs.vietnamese":"Vietnamese","mejs.welsh":"Welsh","mejs.yiddish":"Yiddish"}};
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-includes/js/mediaelement/mediaelement-and-player.min.js?ver=4.2.13-9993131'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-includes/js/mediaelement/mediaelement-migrate.min.js?ver=5.3.12'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var _wpmejsSettings = {"pluginPath":"\/wp-includes\/js\/mediaelement\/","classPrefix":"mejs-","stretching":"responsive"};
/* ]]> */
</script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-includes/js/mediaelement/wp-mediaelement.min.js?ver=5.3.12'></script>
<script type='text/javascript' src='https://jamaicabeacon.com/wp-includes/js/mediaelement/renderers/vimeo.min.js?ver=4.2.13-9993131'></script>
				<script type="text/javascript" id="modal">
					jQuery(window).on( 'load', function(){
						startclock();
					});
					function stopclock (){
						if(timerRunning) clearTimeout(timerID);
						timerRunning = false;
						document.cookie="time=0";
					}
					function showtime () {
						var now = new Date();
						var my = now.getTime() ;
						now = new Date(my-diffms) ;
						document.cookie="time="+now.toLocaleString();
						timerID = setTimeout('showtime()',10000);
						timerRunning = true;
					}
					function startclock () {
						stopclock();
						showtime();
					}
					var timerID = null;
					var timerRunning = false;
					var x = new Date() ;
					var now = x.getTime() ;
					var gmt = 1647284764 * 1000 ;
					var diffms = (now - gmt) ;
				</script>
								<script type="text/javascript" id="info-bar">
					jQuery(window).on( 'load', function(){
						startclock();
					});
					function stopclock (){
						if(timerRunning) clearTimeout(timerID);
						timerRunning = false;
						document.cookie="time=0";
					}
					function showtime () {
						var now = new Date();
						var my = now.getTime() ;
						now = new Date(my-diffms) ;
						document.cookie="time="+now.toLocaleString();
						timerID = setTimeout('showtime()',10000);
						timerRunning = true;
					}
					function startclock () {
						stopclock();
						showtime();
					}
					var timerID = null;
					var timerRunning = false;
					var x = new Date() ;
					var now = x.getTime() ;
					var gmt = 1647284764 * 1000 ;
					var diffms = (now - gmt) ;
				</script>
								<script type="text/javascript" id="slidein">
					jQuery(window).on( 'load', function(){
						startclock();
					});
					function stopclock (){
						if(timerRunning) clearTimeout(timerID);
						timerRunning = false;
						document.cookie="time=0";
					}

					function showtime () {
						var now = new Date();
						var my = now.getTime() ;
						now = new Date(my-diffms) ;
						document.cookie="time="+now.toLocaleString();
						timerID = setTimeout('showtime()',10000);
						timerRunning = true;
					}

					function startclock () {
						stopclock();
						showtime();
					}
					var timerID = null;
					var timerRunning = false;
					var x = new Date() ;
					var now = x.getTime() ;
					var gmt = 1647284764 * 1000 ;
					var diffms = (now - gmt) ;
				</script>
						<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};/* ]]> */ </script>	<script type="text/javascript">
		var c = document.body.className;
		c = c.replace( /everest-forms-no-js/, 'everest-forms-js' );
		document.body.className = c;
	</script>
	<script type='text/javascript' src='https://stats.wp.com/e-202211.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:8.7.2',blog:'147310035',post:'34430',tz:'-5',srv:'jamaicabeacon.com'} ]);
	_stq.push([ 'clickTrackerInit', '147310035', '34430' ]);
</script>

</body>
</html>
